PAT 1115 Counting Nodes in a BST

PAT 1115 Counting Nodes in a BST

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than or equal to the node’s key.
The right subtree of a node contains only nodes with keys greater than the node’s key.
Both the left and right subtrees must also be binary search trees.
Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000) which is the size of the input sequence. Then given in the next line are the N integers in [−10001000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification:
For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n
where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:

9
25 30 42 16 20 20 35 -5 28

Sample Output:

2 + 4 = 6

解题思路:

参考自https://www.liuchuo.net/archives/2235
首先在于还原二叉树;

struct node{
	int v;
	node *left;
	node *right;
};

其次根据二叉搜索树的性质,每次递归还原根节点;

node* build(node *root,int v){
	if(root==NULL){
		root=new node();
		root->v=v;
		root->left=NULL;
		root->right=NULL;
	}else if(v>root->v){
		root->right=build(root->right,v);
	}else{
		root->left=build(root->left,v);
	}
	return root;
}

最后基于深度优先遍历,找到每个节点所属的层数。

#include <iostream>
#include<cstdio>
using namespace std;
struct node{
	int v;
	node *left;
	node *right;
};
int num[10000];
node* build(node *root,int v){
	if(root==NULL){
		root=new node();
		root->v=v;
		root->left=NULL;
		root->right=NULL;
	}else if(v>root->v){
		root->right=build(root->right,v);
	}else{
		root->left=build(root->left,v);
	}
	return root;
}

int maxdepth=-1;
void dfs(node *root,int depth){
	if(root==NULL){
		if(depth>maxdepth) maxdepth=depth;
		return;
	}
	num[depth]++;
	dfs(root->left,depth+1);
	dfs(root->right,depth+1);
}
int main(int argc, char** argv) {
	int n;
	scanf("%d",&n);
	node *root=NULL;
	for(int i=0;i<n;i++){
		int x;
		scanf("%d",&x);
		root=build(root,x);
	}
	dfs(root,0);
	printf("%d + %d = %d",num[maxdepth-1],num[maxdepth-2],num[maxdepth-1]+num[maxdepth-2]);
	return 0;
}
posted @ 2018-11-07 21:52  xzhws  阅读(29)  评论(0编辑  收藏  举报