挑战算法2

2. 成绩排名 

读入n名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。

输入格式:每个测试输入包含1个测试用例,格式为

  第1行:正整数n
  第2行:第1个学生的姓名 学号 成绩
  第3行:第2个学生的姓名 学号 成绩
  ... ... ...
  第n+1行:第n个学生的姓名 学号 成绩
其中姓名和学号均为不超过10个字符的字符串,成绩为0到100之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。

 

输出格式:对每个测试用例输出2行,第1行是成绩最高学生的姓名和学号,第2行是成绩最低学生的姓名和学号,字符串间有1空格。

输入样例:
3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
输出样例:
Mike CS991301
Joe Math990112
代码:
#include<iostream>
using namespace std;
struct student            //定义一个结构类型,存储成员
{
    char name[11];          
    char id[11];
    int score;
};

int main()
{
    int i,n;
    cin>>n;
    student *stu = new student[n];    //声明了一个Student类型的对象变量stu,并在栈内存中为其分配存储空间 
    for(i=0;i<n;i++)              用new关键字为该Student对象在堆内存分配存储空间并将其保存
    {                       保存后返回该Student对象的一个引用并赋值给对象变量stu,这样stu中就保存了Student对象的引用.
        cin>>stu[i].name>>stu[i].id>>stu[i].score;
    }
    int max_score=stu[0].score;        //定义最大分数
    int min_score=stu[0].score;        //定义最小分数
    int max_i=1;
    int min_i=1;
    for(i=2;i<n;i++)
    {
        if(stu[i].score > max_score)
        {
            max_i=i;
            max_score=stu[i].score;
        }
        if(stu[i].score < min_score)
        {
            min_i=i;
            min_score=stu[i].score;
        }
    }
    cout<<stu[max_i].name<<" "<<stu[max_i].id<<endl;
    cout<<stu[min_i].name<<" "<<stu[min_i].id<<endl;
    return 0;
}

  


 

posted @ 2017-09-01 16:32  双人余555  阅读(254)  评论(0编辑  收藏  举报