博客园  :: 首页  :: 新随笔  :: 联系 :: 订阅 订阅  :: 管理

ZOJ_1709 Oil Deposits 求解连通图

Posted on 2010-08-22 16:01  还好  阅读(376)  评论(0编辑  收藏  举报

 

Oil Deposits

 

Time Limit: 1 Second      Memory Limit: 32768 KB

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.


Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.


Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.


Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0


Sample Output

0
1
2
2

 

说到底其实就是求图可以分为多少个连通的部分!不多说了,直接贴代码!

 

代码
#include<iostream>
using namespace std;
int rowNums,colNums;
bool hasVisit[100][100];
char grid[100][100];
int dir[3]={-1,0,1};
void DFS(int row, int col)
{
    
if(row<0||row>=rowNums||col<0||col>=colNums)
    {
        
return;
    }
    
for(int i=0;i<3;i++)
        
for(int j=0;j<3;j++)
        {
            
if(dir[i]==0&&dir[j]==0)continue;
            
int newRow=row+dir[i];
            
int newCol=col+dir[j];            
            
if(newRow>=0&&newRow<rowNums&&newCol>=0&&newCol<colNums)
            {
                
if(grid[newRow][newCol]=='@'&&!hasVisit[newRow][newCol])
                {
                
//    cout<<newRow<<" "<<newCol<<endl;
                    hasVisit[newRow][newCol]=true;
                    DFS(newRow,newCol);
                }
            }
        }
}
int main(void)
{
    
while(cin>>rowNums>>colNums)
    {
        
if(rowNums==0&&colNums==0)return 0;
        
int i,j;
        
for(i=0;i<rowNums;i++)
        {
            
for(j=0;j<colNums;j++)
            {
                cin
>>grid[i][j];
                hasVisit[i][j]
=false;
            }
        }
        
int count=0;
        
for(i=0;i<rowNums;i++)
        {
            
for(j=0;j<colNums;j++)
            {
                
if(!hasVisit[i][j]&&grid[i][j]=='@')
                {
                    hasVisit[i][j]
=true;
                    DFS(i,j);
                    count
++;
                }
            }
        }
        cout
<<count<<endl;
    }

}