十二周+
这个作业属于哪个课程 | C语言程序设计ll |
---|---|
这个作业要求在哪里 | https://edu.cnblogs.com/campus/zswxy/software-engineering-class2-2018/homework/3234 |
我在这个课程的目标是 | 掌握指针与函数 |
这个作业在哪个具体方面帮助我实现目标 | 指针函数的掌握 |
参考文献 | 很多大佬代码 |
基础作业
计算最长的字符串长度
函数接口定义:
int max_len( char *s[], int n );
其中n个字符串存储在s[]中,函数max_len应返回其中最长字符串的长度。
裁判测试程序样例:
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#define MAXN 10
#define MAXS 20
int max_len( char *s[], int n );
int main()
{
int i, n;
char *string[MAXN] = {NULL};
scanf("%d", &n);
for(i = 0; i < n; i++) {
string[i] = (char *)malloc(sizeof(char)*MAXS);
scanf("%s", string[i]);
}
printf("%d\n", max_len(string, n));
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
4
blue
yellow
red
g
reen
输出样例:
6
代码:
int max_len( char *s[], int n )
{
int m=0;
for(int i=0;i<n;i++)
{
int t=strlen(s[i]);
if(m < t)
{
m=t;
}
}
return m;
}
流程图:
运行中遇到的问题:
无
统计专业人数
本题要求实现一个函数,统计学生学号链表中专业为计算机的学生人数。链表结点定义如下:
struct ListNode {
char code[8];
struct ListNode *next;
};
这里学生的学号共7位数字,其中第2、3位是专业编号。计算机专业的编号为02。
函数接口定义:
int countcs( struct ListNode *head );
其中head是用户传入的学生学号链表的头指针;函数countcs统计并返回head链表中专业为计算机的学生人数。
裁判测试程序样例:
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
struct ListNode {
char code[8];
struct ListNode *next;
};
struct ListNode *createlist(); /*裁判实现,细节不表*/
int countcs( struct ListNode *head );
int main()
{
struct ListNode *head;
head = createlist();
printf("%d\n", countcs(head));
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
1021202
2022310
8102134
1030912
3110203
4021205
#
输出样例:
3
代码:
int countcs( struct ListNode *head )
{
int num = 0;
struct ListNode *p = head;
while(p != NULL)
{
if(p->code[1] == '0' && p->code[2] == '2')
num++;
p = p->next;
}
return num;
}
流程图
运行中遇到的问题:
一些简单的编译错误
删除单链表偶数节点
代码:
struct ListNode *createlist()
{
int data;
struct ListNode *head,*p,*tail;
int size=sizeof(struct ListNode);
head=p=NULL;
scanf("%d",&data);
while(data!=-1)
{
p=(struct ListNode*)malloc(size);
p->data=data;
p->next=NULL;
if(head==NULL)
head=p;
else
tail->next=p;
tail=p;
scanf("%d",&data);
}
return head;
}
struct ListNode *deleteeven( struct ListNode *head )
{
struct ListNode *p1,*p2;
while(head!=NULL&&head->data%2==0)
{
p2=head;
head=head->next;
free(p2);
}
if(head==NULL)
return NULL;
p1=head;
p2=head-> next;
while(p2!=NULL)
{
if(p2->data%2==0)
{
p1->next=p2->next;
free(p2);
}
else
p1=p2;
p2=p1->next;
}
return head;
}
这个是查的没有思路
学习总结:
上了两节课,都不是很明白,完成作业也有一些问题,勉勉强强
编程总结:
讨论了一些思路,检查了下代码,还行。
周 | 学习天数 | 代码行数 | 知识点 | 疑惑点 |
---|---|---|---|---|
十二 | 两天 | 93 | 指针与函数 | 一些思路问题 |