hdu 3032 Nim or not Nim? sg函数 难度:0

Nim or not Nim?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1056    Accepted Submission(s): 523


Problem Description
Nim is a two-player mathematic game of strategy in which players take turns removing objects from distinct heaps. On each turn, a player must remove at least one object, and may remove any number of objects provided they all come from the same heap.

Nim is usually played as a misere game, in which the player to take the last object loses. Nim can also be played as a normal play game, which means that the person who makes the last move (i.e., who takes the last object) wins. This is called normal play because most games follow this convention, even though Nim usually does not.

Alice and Bob is tired of playing Nim under the standard rule, so they make a difference by also allowing the player to separate one of the heaps into two smaller ones. That is, each turn the player may either remove any number of objects from a heap or separate a heap into two smaller ones, and the one who takes the last object wins.
 

 

Input
Input contains multiple test cases. The first line is an integer 1 ≤ T ≤ 100, the number of test cases. Each case begins with an integer N, indicating the number of the heaps, the next line contains N integers s[0], s[1], ...., s[N-1], representing heaps with s[0], s[1], ..., s[N-1] objects respectively.(1 ≤ N ≤ 10^6, 1 ≤ S[i] ≤ 2^31 - 1)
 

 

Output
For each test case, output a line which contains either "Alice" or "Bob", which is the winner of this game. Alice will play first. You may asume they never make mistakes.
 

 

Sample Input
2 3 2 2 3 2 3 3
 

 

Sample Output
Alice Bob

 sg函数打表找规律即可

//hdu 3032
//任意分堆 注意 sg函数具体意义
#include <stdio.h>

int main()
{
    int T;
    scanf("%d", &T);
    while(T --)
    {
        int n, ans = 0, m;
        scanf("%d", &n);
        while(n --)
        {
            scanf("%d", &m);
            if(m % 4 == 0) ans ^= (m - 1);
            else if(m % 4 == 3) ans ^= (m + 1);
            else ans ^= m;
        }
        if(ans == 0) puts("Bob");
        else puts("Alice");
    }
    return 0;
}

  

posted @ 2014-11-18 16:44  雪溯  阅读(167)  评论(0编辑  收藏  举报