hdu 1517 A Multiplication Game 段sg 博弈 难度:0

A Multiplication Game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3832    Accepted Submission(s): 2183


Problem Description
Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n.
 

 

Input
Each line of input contains one integer number n.
 

 

Output
For each line of input output one line either 

Stan wins. 

or 

Ollie wins.

assuming that both of them play perfectly.
 

 

Sample Input
162 17 34012226
 

 

Sample Output
Stan wins. Ollie wins. Stan wins.
 

 

Source

 

打了sg表...1 肯定必败 (2,9)必胜 (10,18)必败,(19,36)必胜...总之就是((2*9)^i+1,(2*9)^i*9)必败,其他必胜,总结规律之后,只要判断在哪个区间即可

数据范围本来以为会爆longlong,但是*9没有爆longlong 

 

#include <cstdio>
#include <cstring>
using namespace std;
long long n;
int main(){
    while(scanf("%I64d",&n)!=EOF){
        long long tn=1;
        bool fl=false;
        while(n>tn){
            tn*=9;fl=true;
            if(n<=tn)break;
            tn*=2;fl=false;
        }
        if(fl)printf("Stan wins.\n");
        else printf("Ollie wins.\n");
    }
    return  0;
}

  

posted @ 2014-11-17 18:49  雪溯  阅读(202)  评论(0编辑  收藏  举报