快速切题 poj 2485 Highways prim算法+堆 不完全优化 难度:0

Highways
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 23033   Accepted: 10612

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways so that it will be possible to drive between any pair of towns without leaving the highway system. 

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways. 

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.

Input

The first line of input is an integer T, which tells how many test cases followed. 
The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between village i and village j. There is an empty line after each test case.

Output

For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.

Sample Input

1

3
0 990 692
990 0 179
692 179 0

Sample Output

692

本来n就很小,没有这么做的必要,反而加重了插入负担

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
typedef pair<int ,int > P;
int dis[600][600],n;
bool vis[600];
priority_queue<P,vector<P>,greater<P> >que;
int prim(){
    int ans=0;
    memset(vis,0,sizeof(vis));
    vis[0]=true;
    while(!que.empty())que.pop();
    for(int i=1;i<n;i++)que.push(P(dis[0][i],i));
    int num=1;
    while(!que.empty()&&num<n){
        int tp=que.top().second;int d=que.top().first;que.pop();
      //  printf("tp %d dis %d\n",tp,d);
        if(vis[tp])continue;
        vis[tp]=true;num++;ans=max(d,ans);
        for(int i=0;i<n;i++)if(!vis[i])que.push(P(dis[tp][i],i));
    }
    return ans;
}
int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        scanf("%d",&n);
        for(int i=0;i<n;i++)for(int j=0;j<n;j++)scanf("%d",dis[i]+j);
        int ans=prim();
        printf("%d\n",ans);
    }
    return 0;
}

  

posted @   雪溯  阅读(348)  评论(0编辑  收藏  举报
编辑推荐:
· 开发中对象命名的一点思考
· .NET Core内存结构体系(Windows环境)底层原理浅谈
· C# 深度学习:对抗生成网络(GAN)训练头像生成模型
· .NET 适配 HarmonyOS 进展
· .NET 进程 stackoverflow异常后,还可以接收 TCP 连接请求吗?
阅读排行:
· 本地部署 DeepSeek:小白也能轻松搞定!
· 基于DeepSeek R1 满血版大模型的个人知识库,回答都源自对你专属文件的深度学习。
· 在缓慢中沉淀,在挑战中重生!2024个人总结!
· 如何给本地部署的DeepSeek投喂数据,让他更懂你
· 大人,时代变了! 赶快把自有业务的本地AI“模型”训练起来!
点击右上角即可分享
微信分享提示