【ACM】hdu_zs3_1006_AB_201308101123
A/B
Time Limit : 1000/1000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 6 Accepted Submission(s) : 5
Problem Description
要求(A/B)%9973,但由于A很大,我们只给出n(n=A%9973)(我们给定的A必能被B整除,且gcd(B,9973) = 1)。
Input
数据的第一行是一个T,表示有T组数据。
每组数据有两个数n(0 <= n < 9973)和B(1 <= B <= 10^9)。
Output
对应每组数据输出(A/B)%9973。
Sample Input
2
1000 53
87 123456789
Sample Output
7922
6060
Author
xhd
Source
HDU 2007-1 Programming Contest
#include <stdio.h>
int main()
{
int N;
scanf("%d",&N);
while(N--)
{
int n,m,t=1,k;
scanf("%d %d",&n,&m);
k=n;m%=9973;
while(n%m)
{
t++;
n=k+t*9973;
}
printf("%d\n",n/m%9973);
}
return 0;
}