hdu 1016 DFS

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 57319    Accepted Submission(s): 25008


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

 

 

Input
n (0 < n < 20).
 

 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

题意:给你一个1到n个点的环,1必须在第一位,要相邻两点相加为素数。输出所有情况。

Sample Input
6 8
 

 

Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4
 
 
Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
代码:

 

#include<stdio.h>
#include<string.h>
int visit[30],a[30],n;//a为第几个数 
int su(int x)
{
    for(int i=2;i<x;i++)
        if(x%i==0) return 0;
    return 1;
}
void dfs(int x,int y)//x为深度,也是第几位数,y为1~n中的值 
{
    a[x]=y;
    visit[y]=1;
    if(x==n)//终止条件 
    {
        if(su(a[x]+a[1]))//还要判断一下最后一个与1是否构成素数 
        {
            printf("1");
            for(int i=2;i<=n;i++)
                printf(" %d",a[i]);
            printf("\n");
        }
        return ;
    }
    for(int i=1;i<=n;i++)
    {
        if(!visit[i]&&su(a[x]+i))
        {
            dfs(x+1,i);//如果i与a[x]构成素数,搜索下一层 
            visit[i]=0;//回溯 
        }
    }
    return ;
}
int main()
{
    int sum=1;
    while(scanf("%d",&n)!=EOF)
    {
        printf("Case %d:\n",sum++);
        memset(a,0,sizeof(a));
        dfs(1,1);
        printf("\n");
    }
    return 0;
}

 

posted @ 2018-01-21 10:57  怀揣少年梦.#  阅读(97)  评论(0编辑  收藏  举报