nullnullpoj2585 Window Pains

工作之余抽点时间出来写写博文,希望对新接触的朋友有帮助。今天在这里和大家一起学习一下nullnull

    

Window Pains

    

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 1330   Accepted: 663

    Description

    

Boudreaux likes to multitask, especially when it comes to using his computer. Never satisfied with just running one application at a time, he usually runs nine applications, each in its own window. Due to limited screen real estate, he overlaps these windows and brings whatever window he currently needs to work with to the foreground. If his screen were a 4 x 4 grid of squares, each of Boudreaux's windows would be represented by the following 2 x 2 windows:
1 1 . .
1 1 . .
. . . .
. . . .
. 2 2 .
. 2 2 .
. . . .
. . . .
. . 3 3
. . 3 3
. . . .
. . . .
. . . .
4 4 . .
4 4 . .
. . . .
. . . .
. 5 5 .
. 5 5 .
. . . .
. . . .
. . 6 6
. . 6 6
. . . .
. . . .
. . . .
7 7 . .
7 7 . .
. . . .
. . . .
. 8 8 .
. 8 8 .
. . . .
. . . .
. . 9 9
. . 9 9
When Boudreaux brings a window to the foreground, all of its squares come to the top, overlapping any squares it shares with other windows. For example, if window1and then window 2 were brought to the foreground, the resulting representation would be:
1 2 2 ?
1 2 2 ?
? ? ? ?
? ? ? ?
If window 4 were then brought to the foreground:
1 2 2 ?
4 4 2 ?
4 4 ? ?
? ? ? ?
. . . and so on . . .
Unfortunately, Boudreaux's computer is very unreliable and crashes often. He could easily tell if a crash occurred by looking at the windows and seeing a graphical representation that should not occur if windows were being brought to the foreground correctly. And this is where you come in . . .
    每日一道理
书籍好比一架梯子,它能引领人们登上文化的殿堂;书籍如同一把钥匙,它将帮助我们开启心灵的智慧之窗;书籍犹如一条小船,它会载着我们驶向知识的海洋。

    Input

    

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.

A single data set has 3 components:
  1. Start line - A single line:
    START

  2. Screen Shot - Four lines that represent the current graphical representation of the windows on Boudreaux's screen. Each position in this 4 x 4 matrix will represent the current piece of window showing in each square. To make input easier, the list of numbers on each line will be delimited by a single space.
  3. End line - A single line:
    END

After the last data set, there will be a single line:
ENDOFINPUT

Note that each piece of visible window will appear only in screen areas where the window could appear when brought to the front. For instance, a 1 can only appear in the top left quadrant.

    Output

    

For each data set, there will be exactly one line of output. If there exists a sequence of bringing windows to the foreground that would result in the graphical representation of the windows on Boudreaux's screen, the output will be a single line with the statement:

THESE WINDOWS ARE CLEAN

Otherwise, the output will be a single line with the statement:
THESE WINDOWS ARE BROKEN

    Sample Input

START
1 2 3 3
4 5 6 6
7 8 9 9
7 8 9 9
END
START
1 1 3 3
4 1 3 3

7 7 9 9
7 7 9 9
END
ENDOFINPUT

    Sample Output

THESE WINDOWS ARE CLEAN
THESE WINDOWS ARE BROKEN
 
对于窗体i,j,如果j覆盖了窗口i,就建一条由i到j的边,这样根据给出的窗口状态就可以建一个有向图了,正常情况下该有向图应该没有环。所以如果电脑死机了,则该有向图就不存在拓扑序列。
 
#include <iostream>
#include<cstring>
#include<cstdio>

using namespace std;
int state[5][5];
int map[10][10];//邻接矩阵
int in[10];//入度

bool TopSort()
{
    int stack[9],top;
    top=0;
    for(int i=1;i<=9;i++)
        if(in[i]==0)
            stack[top++]=i;
    while(top)
    {
        int t=stack[--top];
        for(int i=1;i<=9;i++)
            if(map[t][i])
            {
                in[i]--;
                if(in[i]==0)
                    stack[top++]=i;
            }
    }
    for(int i=1;i<=9;i++)
        if(in[i])
            return false;
    return true;
}

int main()
{
    char str[20];
    int i,j;
    while(scanf("%s",str))
    {
        if(strcmp(str,"ENDOFINPUT")==0)
            break;
        for(i=1;i<=4;i++)
            for(j=1;j<=4;j++)
                scanf("%d",&state[i][j]);
        scanf("%s",str);
        memset(map,0,sizeof(map));
        memset(in,0,sizeof(in));
        for(i=1;i<4;i++)
            for(j=1;j<4;j++)
            {
                int k=(i-1)*3+j;//窗口号
                if(state[i][j]!=k)
                {
                    if(!map[k][state[i][j]])
                    {
                        map[k][state[i][j]]=1;
                        in[state[i][j]]++;
                    }
                }
                if(state[i][j+1]!=k)
                {
                    if(!map[k][state[i][j+1]])
                    {
                        map[k][state[i][j+1]]=1;
                        in[state[i][j+1]]++;
                    }
                }
                if(state[i+1][j]!=k)
                {
                    if(!map[k][state[i+1][j]])
                    {
                        map[k][state[i+1][j]]=1;
                        in[state[i+1][j]]++;
                    }
                }
                if(state[i+1][j+1]!=k)
                {
                    if(!map[k][state[i+1][j+1]])
                    {
                        map[k][state[i+1][j+1]]=1;
                        in[state[i+1][j+1]]++;
                    }
                }
            }
        if(TopSort())
            printf("THESE WINDOWS ARE CLEAN\n");
        else
            printf("THESE WINDOWS ARE BROKEN\n");
    }
    return 0;
}
 

文章结束给大家分享下程序员的一些笑话语录: 马云喜欢把自己包装成教主,张朝阳喜欢把自己包装成明星,李彦宏喜欢把自己包装成的很知性,丁磊喜欢把自己包装的有创意,李开复总摆出一副叫兽的样子。看来的。其实我想说,缺啥补啥,人之常情。

posted @ 2013-05-21 22:11  xinyuyuanm  阅读(148)  评论(0编辑  收藏  举报