[NOIP1998 普及组] 阶乘之和——高精度运算

题目描述

用高精度计算出 \(S = 1! + 2! + 3! + \cdots + n!\)\(n \le 50\))。

其中 ! 表示阶乘,定义为 \(n!=n\times (n-1)\times (n-2)\times \cdots \times 1\)。例如,\(5! = 5 \times 4 \times 3 \times 2 \times 1=120\)

输入格式

一个正整数 \(n\)

输出格式

一个正整数 \(S\),表示计算结果。

样例 #1

样例输入 #1

3

样例输出 #1

9

提示

【数据范围】

对于 \(100 \%\) 的数据,\(1 \le n \le 50\)

【其他说明】

注,《深入浅出基础篇》中使用本题作为例题,但是其数据范围只有 \(n \le 20\),使用书中的代码无法通过本题。

如果希望通过本题,请继续学习第八章高精度的知识。

NOIP1998 普及组 第二题

思路就是先循环每乘一次,加上当前值。

#include <stdio.h>
#include <stdlib.h>
int temp[101]={0};
int res[101]={0};
void jieCheng(int n) {
	int carry=0;
	for (int i=100;i>=0;i--) {
		temp[i]=temp[i]*n+carry;
		carry=temp[i]/10;
		temp[i]=temp[i]%10;
	}
}
void qiuHe() {
	int carry=0;
	for (int i=100;i>=0;i--) {
		res[i]+=temp[i]+carry;
		carry=res[i]/10;
		res[i]=res[i]%10;
	}
}
int main() {
	int n;
	scanf("%d",&n);
	temp[100]=1;
	for (int i=1;i<=n;i++) {
		jieCheng(i);
		qiuHe();
	}
	int flag=0;
	for (int i=0;i<101;i++) {
		if (res[i]!=0) flag=1;
		if (flag==1) printf("%d",res[i]);
	}
}
posted @ 2024-12-30 10:37  xiins  阅读(7)  评论(0编辑  收藏  举报