第十二周作业
|这个作业属于哪个课程| C语言程序设计II |
| -------- | -----: | :----: |
|这个作业要求在哪里|https://edu.cnblogs.com/campus/zswxy/software-engineering-class1-2018/homework/3235|
|我在这个课程的目标是|学习指针的进阶|
|这个作业在哪个具体方面帮我实现目标|指针的使用|
|参考文献| 课本C语言程序设计|
计算最长的字符串长度 (15 分)
本题要求实现一个函数,用于计算有n个元素的指针数组s中最长的字符串的长度。
函数接口定义:
int max_len( char *s[], int n );
其中n个字符串存储在s[]中,函数max_len应返回其中最长字符串的长度。
裁判测试程序样例:
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#define MAXN 10
#define MAXS 20
int max_len( char *s[], int n );
int main()
{
int i, n;
char *string[MAXN] = {NULL};
scanf("%d", &n);
for(i = 0; i < n; i++) {
string[i] = (char *)malloc(sizeof(char)*MAXS);
scanf("%s", string[i]);
}
printf("%d\n", max_len(string, n));
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
4
blue
yellow
red
green
输出样例:
6
1).实验代码
int max_len( char *s[], int n )
{
int max=0;
int u;
for(u=0;u<n;u++){
if(strlen(s[max])<strlen(s[u]))
{
max=u;
}
}
return strlen(s[max]);
}
2).设计思路
3).本题遇到的困难及解决方法
暂无
4).程序运行截图
统计专业人数 (15 分)
本题要求实现一个函数,统计学生学号链表中专业为计算机的学生人数。链表结点定义如下:
struct ListNode {
char code[8];
struct ListNode *next;
};
这里学生的学号共7位数字,其中第2、3位是专业编号。计算机专业的编号为02。
函数接口定义:
int countcs( struct ListNode *head );
其中head是用户传入的学生学号链表的头指针;函数countcs统计并返回head链表中专业为计算机的学生人数。
裁判测试程序样例:
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
struct ListNode {
char code[8];
struct ListNode *next;
};
struct ListNode *createlist(); /*裁判实现,细节不表*/
int countcs( struct ListNode *head );
int main()
{
struct ListNode *head;
head = createlist();
printf("%d\n", countcs(head));
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
1021202
2022310
8102134
1030912
3110203
4021205
#
输出样例:
3
1).实验代码
int countcs( struct ListNode *head )
{
int len = 0;
while(head)
{
if(head->code[1] == '0' && head->code[2] == '2')
len++;
head = head->next;
}
return len;
}
2).设计思路
3).本题遇到的问题及解决方法
可能是上课没怎么听的原因,无从下笔,听了室友的讲解才有了思路
4).程序运行截图
删除单链表偶数节点 (20 分)
本题要求实现两个函数,分别将读入的数据存储为单链表、将链表中偶数值的结点删除。链表结点定义如下:
struct ListNode {
int data;
struct ListNode *next;
};
函数接口定义:
struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );
函数createlist从标准输入读入一系列正整数,按照读入顺序建立单链表。当读到−1时表示输入结束,函数应返回指向单链表头结点的指针。
函数deleteeven将单链表head中偶数值的结点删除,返回结果链表的头指针。
裁判测试程序样例:
#include <stdio.h>
#include <stdlib.h>
struct ListNode {
int data;
struct ListNode *next;
};
struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );
void printlist( struct ListNode *head )
{
struct ListNode *p = head;
while (p) {
printf("%d ", p->data);
p = p->next;
}
printf("\n");
}
int main()
{
struct ListNode *head;
head = createlist();
head = deleteeven(head);
printlist(head);
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
1 2 2 3 4 5 6 7 -1
输出样例:
1 3 5 7
1).实验代码
struct ListNode *createlist() //是借鉴组内队员的,在队员的帮助下理解了这题目//
{
struct ListNode *head,*p;
int n;
head=(struct ListNode *)malloc(sizeof(struct ListNode));
p=head;
head->next=NULL;
while(1)
{
p->next=(struct ListNode *)malloc(sizeof(struct ListNode));
scanf("%d",&n);
if(n==-1)
{
break;
}
p=p->next;
p-> data=n;
p->next=NULL;
}
head=head->next;
return (head);
}
struct ListNode *deleteeven(struct ListNode *head)
{
struct ListNode *p,*q;
if(head==NULL)
{
return NULL;
}
p=head;
q=p->next;
while(q!=NULL)
{
if(q->data%2==0)
{
p->next=q->next;
free(q);
q=p->next;
}
else
{
p=p->next;
q=p->next;
}
}
if(head->data%2==0)
{
head=head->next;
}
return (head);
}
2).设计思路
3).本题遇到的问题及解决方法4
问题太多了,都是靠组内队员帮助完成的
4).程序运行截图
预习作业
1.所在小组想要开发的项目的名称和目标
项目:小游戏
目标:能够打发闲暇时间
2.项目主体功能的描述
能够帮助人们打发无聊时间
3.现阶段已做的准备工作;
正在找资料
4.小组成员名单和进度安排。(课程设计阶段:13-17周)
小组成员:黄璇,谢鑫,陶祥庭,薛胜科。