POJ - 1579 :Function Run Fun

We all love recursion! Don't we?

Consider a three-parameter recursive function w(a, b, c):

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:
1

if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:
w(20, 20, 20)

if a < b and b < c, then w(a, b, c) returns:
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)

otherwise it returns:
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.
Input

The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.

Output

Print the value for w(a,b,c) for each triple.

Sample Input

1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1

Sample Output

w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1


给出了递归式,我们只需将其记忆化即可。

Select Code
#include<iostream>

using namespace std;

int a[25][25][25];

int dp(int x,int y,int z)
{
	if(x<=0||y<=0||z<=0)
		return 1;
	if(x>20||y>20||z>20)
		return dp(20,20,20);
	if(a[x][y][z]!=0)
		return a[x][y][z];
	if(x<y&&y<z)
	{
		a[x][y][z]=dp(x,y,z-1)+dp(x,y-1,z-1)-dp(x,y-1,z);
		return a[x][y][z];
	}
		else
		{
			a[x][y][z]=dp(x-1,y,z)+dp(x-1,y,z-1)+dp(x-1,y-1,z)-dp(x-1,y-1,z-1);
			return a[x][y][z];
		}
	
}

int main()
{
	int x,y,z;
	while(cin>>x>>y>>z)
	{
		if(x==y&&y==z&&x==-1)
			return 1;
		printf("w(%d, %d, %d) = %d",x,y,z,dp(x,y,z));
		cout<<endl;
	}
	
	return 0;
}
posted @ 2017-07-27 15:12  西北会法语  阅读(144)  评论(0编辑  收藏  举报