HDU - 2199 :Can you solve this equation? (二分)

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.InputThe first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

OutputFor each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100

Sample Input

2
100
-4

Sample Output

1.6152
No solution!

根据数学表达式用二分方法求近似解。

源代码:
#include<iostream>
#include<algorithm>
#include <iomanip>

using namespace std;

int main() {
int T,a;
cin>>T;
while(T--)
{
cin>>a;
a=a-6;
double low=0,hign=100,x,z;

if(a<0 || a>807020300)
cout<<"No solution!"<<endl;
else
{
while((hign-low)>1e-10)
{
x=(low+hign)/2;
z=8*x*x*x*x + 7*x*x*x+ 2*x*x + 3*x;
if(z>a)
hign=x;
if(z==a)
break;
if(z<a)
low=x;
}
cout<< setprecision(4)<<fixed<<x<<endl;
}

}

return 0;
}
posted @ 2017-07-26 15:34  西北会法语  阅读(223)  评论(0编辑  收藏  举报