HDU 1896 : Stones

Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time.
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first.
InputIn the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases.
For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.
OutputJust output one line for one test case, as described in the Description.
Sample Input

2
2
1 5
2 4
2
1 5
6 6

Sample Output

11
12

题目大意是小s的在放学路上有很多石头,输入这些石头的坐标和能把它掷出的距离,(从遇到的第一个石头开始数,单数掷出,双数不理)。问在走了一遍后,最远石头离起点的位置。
(hint,如果两个或以上石头在一起则先碰到大的石头(就是能掷出距离近的那个))
解法,构造一个优先队列,重载小于,将近的石头放在队头,双数出队,单数出队再入队。如此往复直至队列为空,最后出队的值即为所求。

源代码:

#include<iostream>
#include<queue>


using namespace std;

struct s
{
int a;
int b;
};

bool operator<(s x,s y)
{
if(x.a==y.a)
return x.b>y.b;
return x.a>y.a;
}

int main() {
int t;
cin>>t;
while(t--)
{
int t1;
cin>>t1;
s g;
priority_queue<s> p;
for(int i=0;i<t1;i++)
{
cin>>g.a>>g.b;
p.push(g);
}
int sum=1;
while(!p.empty())
{
g=p.top();
p.pop();
if(sum%2)
{
g.a=g.a+g.b;
p.push(g);
}
sum++;
}
cout<<g.a<<endl;
}

return 0;
}


posted @ 2017-07-26 14:34  西北会法语  阅读(159)  评论(0编辑  收藏  举报