HDU-1212Big Number

Problem Description
As we know, Big Number is always troublesome. But it's really important in our ACM. And today, your task is to write a program to calculate A mod B.
To make the problem easier, I promise that B will be smaller than 100000.
Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.
 
Input
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.
 
Output
For each test case, you have to ouput the result of A mod B.
 
Sample Input
2 3 12 7 152455856554521 3250
 
Sample Output
2 5 1521
 
AC代码:
 
#include<stdio.h>
#include<string.h>
char A[10005];
int n;
int main() {
 while(scanf("%s%d",A,&n)!=EOF) {
  int len=strlen(A);
  int sum=0;
  for(int i=0;i<len;i++) {
   sum=10*sum+A[i]-'0';
   sum=sum%n;
  }
  printf("%d\n",sum);
 }
 return 0;
}
posted @ 2013-04-14 00:44  xiaxiaosheng  阅读(92)  评论(0编辑  收藏  举报