Path of Equal Weight (DFS)

Path of Equal Weight (DFS)

 

Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

 

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in Figure 1: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in Figure 1.

 


Figure 1

Input Specification:

 

Each input file contains one test case. Each case starts with a line containing 0 < N <= 100, the number of nodes in a tree, M (< N), the number of non-leaf nodes, and 0 < S < 230, the given weight number. The next line contains N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:

 

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

 

Output Specification:

 

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

 

Note: sequence {A1, A2, ..., An} is said to be greater than sequence {B1, B2, ..., Bm} if there exists 1 <= k < min{n, m} such that Ai = Bi for i=1, ... k, and Ak+1 > Bk+1.

 

Sample Input:

20 9 24

10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2

00 4 01 02 03 04

02 1 05

04 2 06 07

03 3 11 12 13

06 1 09

07 2 08 10

16 1 15

13 3 14 16 17

17 2 18 19

Sample Output:

10 5 2 7

10 4 10

10 3 3 6 2

10 3 3 6 2

 

 

这道30分的题目,提交一次就意外的AC了。

 

就是 建立连接表 DFS+记录路径+权值累加 搜到叶子节点,如果权值之和与要求的的相等时保存路径。

 

最后的排序要点混,但进行三层的判断排序,也就能过了,


#include <iostream>

#include <string>

#include <vector>

#include <algorithm>

using namespace std;

 

int WW[100];

int visit[100];

vector<int> vv[100];

 

vector<int> road;

 

vector<int> RR[100];

 

int sum,wi;

 

bool cmp(vector<int> a,vector<int> b)

{

      if(a[0]==b[0]&&a[1]==b[1])

            return a[2]>b[2];

      if(a[0]==b[0])

      return      a[1]>b[1];

 

      return      a[0]>b[0];

 

}

 

void DFS(int root,int &count)

{

    if(visit[root]==0)

      {

         visit[root]=1;

         road.push_back(WW[root]);

       sum+=WW[root];

 

         for(int i=0;i<vv[root].size();i++)

         {

            if(visit[vv[root][i]]==0)

                    DFS(vv[root][i],count);

         }

         if(sum==wi&&vv[root].size()==0)

         {

            RR[count++]=road;

            

         }

          road.pop_back();

            sum-=WW[root];

 

      }

}

 

 

 

int main()

{

     

      int i,j,num,fnum;

      while(cin>>num)

      {

           

      road.clear(); 

 

        cin>>fnum>>wi;

        for(i=0;i<num;i++)

        {

              cin>>WW[i];

              vv[i].clear();

              visit[i]=0;

              RR[i].clear();

        }

 

        for(i=0;i<fnum;i++)

        {

              int n1,n2;

           cin>>n1>>n2;

            for(j=0;j<n2;j++)

            {

                int tem;

                  cin>>tem;

                  vv[n1].push_back(tem);

            }

        }

 

      int count=0;

         sum=0;

         DFS(0,count);

 

      sort(RR,RR+count,cmp);

      

        for(i=0;i<count;i++)

        {

           cout<<RR[i][0];

            for(j=1;j<RR[i].size();j++)

                  cout<<" "<<RR[i][j];

            cout<<endl;

        }

      }

 

  return 0;

}


posted @ 2015-01-19 08:01  小爷  阅读(411)  评论(0编辑  收藏  举报