7-3 出租 (20分)

 

7-3 出租 (20分)
 

下面是新浪微博上曾经很火的一张图:

一时间网上一片求救声,急问这个怎么破。其实这段代码很简单,index数组就是arr数组的下标,index[0]=2 对应 arr[2]=1index[1]=0 对应 arr[0]=8index[2]=3 对应 arr[3]=0,以此类推…… 很容易得到电话号码是18013820100

本题要求你编写一个程序,为任何一个电话号码生成这段代码 —— 事实上,只要生成最前面两行就可以了,后面内容是不变的。

输入格式:

输入在一行中给出一个由11位数字组成的手机号码。

输出格式:

为输入的号码生成代码的前两行,其中arr中的数字必须按递减顺序给出。

输入样例:

18013820100
 

输出样例:

int[] arr = new int[]{8,3,2,1,0};
int[] index = new int[]{3,0,4,3,1,0,2,4,3,4,4};
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <vector>
#include <queue>

using namespace std;
typedef long long ll;

int book[10], b[10];
int main() {
    ios::sync_with_stdio(false);
    int t;
    string s;
    cin>>s;
    for(int i = 0;i<s.size();i++){
        book[s[i]-'0']++;
    }
    int arr[10];
    int cnt = 0;

    for(int i = 9;i>=0;i--){
        if(book[i]) {
            arr[cnt++] = i;
            b[i] = cnt-1;
        }
    }

    int index[15];
    for(int i = 0;i<s.size();i++){
        index[i] = b[s[i]-'0'];
    }
    cout<<"int[] arr = new int[]{";
    for(int i = 0;i<cnt;i++){
        cout<<arr[i];
        if(i!=cnt-1)    cout<<',';
        else    cout<<"};\n";
    }
    cout<<"int[] index = new int[]{";
    for(int i = 0;i<s.size();i++){
        cout<<index[i];
        if(i!=s.size()-1)   cout<<",";
        else    cout<<"};\n";
    }
    return 0;
}

 

posted on 2020-08-02 14:47  llllIYIlIN  阅读(227)  评论(0编辑  收藏  举报

导航