母函数

母函数详解:http://blog.csdn.net/lishuhuakai/article/details/8044431

 

Square Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8090    Accepted Submission(s): 5487


Problem Description
People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland.
There are four combinations of coins to pay ten credits:

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin.

Your mission is to count the number of ways to pay a given amount using coins of Silverland.
 

Input
The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.
 

Output
For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.
 

Sample Input
  
2 10 30 0
 

Sample Output
  
1 4 27
 

虽然说别人都说比较简单,但是我表示没有发现。。。。。。

借用别人的代码。。。。。。。。

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<stdlib.h>
const int MAX=32768+10;
long long d[MAX];//#define MAX 40000
//long long d[MAX];
void solve()
{
   int i,j,n;
   while(~scanf("%d",&n),n)              
   {
    memset(d,0,sizeof(d));
    d[0]=1;
      for(i=1;i<=floor(sqrt(n));i++)
   {                                                                                 看的我是很费解啊。。。。
    for(j=i*i;j<=n;j++)
     d[j]+=d[j-i*i];
   }
    printf("%lld\n",d[n]); 
   }
}
int main(void)
{
  solve();
  return 0;
}

posted @   wojiaohuangyu  阅读(4)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 终于写完轮子一部分:tcp代理 了,记录一下
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
点击右上角即可分享
微信分享提示