hdu-2115

I Love This Game

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5596    Accepted Submission(s): 1941


Problem Description
Do you like playing basketball ? If you are , you may know the NBA Skills Challenge . It is the content of the basketball skills . It include several parts , such as passing , shooting , and so on. After completion of the content , the player who takes the shortest time will be the winner . Now give you their names and the time of finishing the competition , your task is to give out the rank of them ; please output their name and the rank, if they have the same time , the rank of them will be the same ,but you should output their names in lexicographic order.You may assume the names of the players are unique.

Is it a very simple problem for you? Please accept it in ten minutes.
 

Input
This problem contains multiple test cases! Ease test case contain a n(1<=n<=10) shows the number of players,then n lines will be given. Each line will contain the name of player and the time(mm:ss) of their finish.The end of the input will be indicated by an integer value of zero.
 

Output
The output format is shown as sample below.
Please output the rank of all players, the output format is shown as sample below;
Output a blank line between two cases.
 

Sample Input
   
10 Iverson 17:19 Bryant 07:03 Nash 09:33 Wade 07:03 Davies 11:13 Carter 14:28 Jordan 29:34 James 20:48 Parker 24:49 Kidd 26:46 0
 

Sample Output
   
Case #1 Bryant 1 Wade 1 Nash 3 Davies 4 Carter 5 Iverson 6 James 7 Parker 8 Kidd 9 Jordan 10
 题目分析:
其实做这道题之前我是参考别人的代码的。
我自己对结构体不算太熟练,还处于刚刚接触的地步。我知道自己很水的。
使用结构体解这类题目比较方便,
代码如下:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node{
char name[100];
int m;
int s;
int time;
int num;
}d[11];
int cmp(node x,node y){
return (x.time==y.time? strcmp(x.name,y.name)>1:x.time<y.time);
}
int main()
{
  int n,i,k=1;
  while(~scanf("%d",&n),n!=0){
  for(i=0;i<n;i++){
  scanf("%s%d:%d",d[i].name,&d[i].m,&d[i].s);
  d[i].time=d[i].m*60+d[i].s;
  }
  sort(d,d+n,cmp);
  if(k!=1){
  printf("\n");
  }
  printf("Case #%d\n",k++);
  for(i=0;i<n;i++){
  if(i>=1&&d[i].time==d[i-1].time)
    d[i].num=d[i-1].num;
  else 
    d[i].num=i+1;


    printf("%s %d\n",d[i].name,d[i].num);
  }
  }
return 0;
}   注意输出格式

posted @   wojiaohuangyu  阅读(4)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 终于写完轮子一部分:tcp代理 了,记录一下
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
点击右上角即可分享
微信分享提示