poj-2092

Grandpa is Famous
Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 7661 Accepted: 3857

Description

The whole family was excited by the news. Everyone knew grandpa had been an extremely good bridge player for decades, but when it was announced he would be in the Guinness Book of World Records as the most successful bridge player ever, whow, that was astonishing! 
The International Bridge Association (IBA) has maintained, for several years, a weekly ranking of the best players in the world. Considering that each appearance in a weekly ranking constitutes a point for the player, grandpa was nominated the best player ever because he got the highest number of points. 
Having many friends who were also competing against him, grandpa is extremely curious to know which player(s) took the second place. Since the IBA rankings are now available in the internet he turned to you for help. He needs a program which, when given a list of weekly rankings, finds out which player(s) got the second place according to the number of points.

Input

The input contains several test cases. Players are identified by integers from 1 to 10000. The first line of a test case contains two integers N and M indicating respectively the number of rankings available (2 <= N <= 500) and the number of players in each ranking (2 <= M <= 500). Each of the next N lines contains the description of one weekly ranking. Each description is composed by a sequence of M integers, separated by a blank space, identifying the players who figured in that weekly ranking. You can assume that: 
  • in each test case there is exactly one best player and at least one second best player, 
  • each weekly ranking consists of M distinct player identifiers.

The end of input is indicated by N = M = 0.

Output

For each test case in the input your program must produce one line of output, containing the identification number of the player who is second best in number of appearances in the rankings. If there is a tie for second best, print the identification numbers of all second best players in increasing order. Each identification number produced must be followed by a blank space.

Sample Input

4 5
20 33 25 32 99
32 86 99 25 10
20 99 10 33 86
19 33 74 99 32
3 6
2 34 67 36 79 93
100 38 21 76 91 85
32 23 85 31 88 1
0 0

Sample Output

32 33
1 2 21 23 31 32 34 36 38 67 76 79 88 91 93 100
 
题目分析:
我个人认为使用结构体比较简单,
代码如下:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node{
	int num;
	int s;
};
int cmp(node x,node y){
	if(x.s==y.s)
	   return x.num<y.num;
	else
	   return x.s>y.s;
}
int main(){
	int i,j,k,t;
	int N,M;
	while(~scanf("%d%d",&N,&M),N!=0&&M!=0){
		node p[10010];
		int temp;
		memset(p,0,sizeof(p));
		for(i=0;i<N;i++)
		   for(j=0;j<M;j++){
		   	scanf("%d",&temp);
		   	p[temp].num=temp;
		   	p[temp].s++;
		   }
		   sort(p,p+10010,cmp);
		   i=1;
		   while(p[i].s==p[i+1].s){
		   	 printf("%d ",p[i].num);
		   	 i++;
		   }
		   printf("%d\n",p[i].num);
	}
	return 0;
}
posted @   wojiaohuangyu  阅读(6)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 终于写完轮子一部分:tcp代理 了,记录一下
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
点击右上角即可分享
微信分享提示