hduSeinfeld

Seinfeld

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1405    Accepted Submission(s): 695


Problem Description
I’m out of stories. For years I’ve been writing stories, some rather silly, just to make simple problems look difficult and complex problems look easy. But, alas, not for this one.
You’re given a non empty string made in its entirety from opening and closing braces. Your task is to find the minimum number of “operations” needed to make the string stable. The definition for being stable is as follows:
1. An empty string is stable.
2. If S is stable, then {S} is also stable.
3. If S and T are both stable, then ST (the concatenation of the two) is also stable.
All of these strings are stable: {}, {}{}, and {{}{}}; But none of these: }{, {{}{, nor {}{.
The only operation allowed on the string is to replace an opening brace with a closing brace, or visa-versa.
 

Input
Your program will be tested on one or more data sets. Each data set is described on a single line. The line is a non-empty string of opening and closing braces and nothing else. No string has more than 2000 braces. All sequences are of even length.
The last line of the input is made of one or more ’-’ (minus signs.)

 

Output
For each test case, print the following line:
k. N
Where k is the test case number (starting at one,) and N is the minimum number of operations needed to convert the given string into a balanced one.
Note: There is a blank space before N.
 

Sample Input
  
}{ {}{}{} {{{} ---
 

Sample Output
  
1. 2 2. 0 3. 1
题目归结起来就是括号的配对
做这道题目有很多种方法
我参看别人的代码,
而且这是第一次使用栈
代码如下:
#include<stdio.h>
#include<stack>
using namespace std;
char str[1200];
int main(){
	int m=0;
	char r,l;
	stack<char>s;     //建立一个栈 
	while(~scanf("%s",str),str[0]!='-'){
		for(int i=0;str[i]!='\0';i++){
			if(str[i]=='}'){
				if(!s.empty()&&s.top()=='{')
				   s.pop();          //empty()是判断是否是空值 
				else                 //pop是消值 
				   s.push(str[i]);    //push是存入栈 
			}
			else  s.push(str[i]);
		}
		int ans=0;
		while(!s.empty()){
			r=s.top();        //取得最前面的字符 
			s.pop();          //然后删除 
			l=s.top();       //取得最后一个的字符 
			s.pop();         //删除 
			if(r=='{')   ans++;
			if(l=='}')   ans++;
		}
		printf("%d. %d\n",++m,ans);
	}
	return 0;
}

posted @   wojiaohuangyu  阅读(6)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 终于写完轮子一部分:tcp代理 了,记录一下
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
点击右上角即可分享
微信分享提示