hdu-1518 Square
Square
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 8922 Accepted Submission(s): 2903
Problem Description
Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?
Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.
Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".
Sample Input
3 4 1 1 1 1 5 10 20 30 40 50 8 1 7 2 6 4 4 3 5
Sample Output
yes
no
yes
i在不同地方定义有时也会产生不同的效果,甚至会让你wa,所以要注意每一点是很重要的
代码如下:
#include<stdio.h>
#include<string.h>
int sum,flag;
int stick[30];
int mark[30];
int n; //刚开始将i定义为全局变量,以为下边就不用定义了
void dfs(int side,int l,int k){ //这样应该很方便的的,但是这样却错了
int i; //所以定义变量的时候位置也很重要
if(side==5){
flag=1;
return;
}
if(l==sum){
dfs(side+1,0,0);
if(flag)
return ;
}
for(i=k;i<n;i++){
if(!mark[i]&&l+stick[i]<=sum){
mark[i]=1;
dfs(side,stick[i]+l,i+1);
if(flag)
return ;
mark[i]=0;
}
}
}
int main(){
int t;
scanf("%d",&t);
// printf("%d\n",t);
while(t--){
int i;
sum=0;
memset(stick,0,sizeof(stick));
memset(mark,0,sizeof(mark));
scanf("%d",&n);
for(i=0;i<n;i++){
scanf("%d",&stick[i]);
sum+=stick[i];
}
// printf("%d\n",sum);
if(sum%4!=0){
printf("no\n");
continue;
}
sum/=4;
for(i=0;i<n;i++)
{
if(stick[i]>sum)
break;
}
if(i!=n){
printf("no\n");
continue;
}
flag=0;
dfs(1,0,0);
if(flag)
printf("yes\n");
else
printf("no\n");
}
return 0;
}
【推荐】国内首个AI IDE,深度理解中文开发场景,立即下载体验Trae
【推荐】编程新体验,更懂你的AI,立即体验豆包MarsCode编程助手
【推荐】抖音旗下AI助手豆包,你的智能百科全书,全免费不限次数
【推荐】轻量又高性能的 SSH 工具 IShell:AI 加持,快人一步
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
· 终于写完轮子一部分:tcp代理 了,记录一下
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理