hdu 1060 Leftmost Digit

Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the leftmost digit of N^N.
 

Sample Input
  
2 3 4
 

Sample Output
  
2 2
这道题目考的是数学问题,不过还有些类型间的转换,m=log10(n^n)=n*log10(n);
floor函数,这个函数是取不大于一个数的最大数,pow(a,b)函数,是求a^b;的函数
代码如下:
#include<stdio.h>
#include<math.h>
int main(){
	int T; 
	int n;
	double m;
	scanf("%d",&T);
	while(T--){
		scanf("%d",&n);
		m=n*log10(n+0.0);
		m-=floor(m);
		double num=pow(10,m);
		printf("%.lf\n",floor(num));
	}
	return 0;
}


posted @   wojiaohuangyu  阅读(3)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 终于写完轮子一部分:tcp代理 了,记录一下
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
点击右上角即可分享
微信分享提示