hdu- 1028 Ignatius and the Princess III

Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
  
4 10 20
 

Sample Output
  
5 42 627
最基础的最简单的母函数的模板题目,
如果不会的话,最起码先要把模板给记住。。。
代码:
#include<stdio.h>
#include<string.h>
int main(){
	int a[150];
    int b[200];
	int N;
	int i,j,k,t;
	while(~scanf("%d",&N)){
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		for(i=0;i<=N;i++){
			a[i]=1;
		}
		for(i=2;i<=N;i++){
			for(j=0;j<=N;j++)
				for(k=0;k+j<=N;k+=i)
				   b[j+k]+=a[j];
			
			for(t=0;t<=N;t++){
			a[t]=b[t];
            b[t]=0;
		}
	}
	//	int sum=0;
	
		printf("%d\n",a[N]);
	}
	return 0;
}


posted @   wojiaohuangyu  阅读(4)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 终于写完轮子一部分:tcp代理 了,记录一下
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
点击右上角即可分享
微信分享提示