hdu -3502 Calculation 2

Problem Description
Given a positive integer N, your task is to calculate the sum of the positive integers less than N which are not coprime to N. A is said to be coprime to B if A, B share no common positive divisors except 1.
 

Input
For each test case, there is a line containing a positive integer N(1 ≤ N ≤ 1000000000). A line containing a single 0 follows the last test case.
 

Output
For each test case, you should print the sum module 1000000007 in a line.
 

Sample Input
  
3 4 0
 

Sample Output
  
0 2
 
#include<stdio.h>
#include<algorithm>
using namespace std;
const int F=1000000007;
__int64 ola(__int64 n){
	__int64 sum=n;
	for(int i=2;i*i<=n;i++){
		if(n%i==0)
		   sum-=sum/i;
		while(n%i==0)
		   n/=i;
	}
	if(n>1)
	   sum-=sum/n;
	return sum;
}
int main(){
	__int64 sum,n;
	while(~scanf("%I64d",&n),n!=0){
		sum=n*(n-1)/2;
		sum-=ola(n)*n/2;
		printf("%I64d\n",sum%F);
	}
}

posted @   wojiaohuangyu  阅读(2)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 终于写完轮子一部分:tcp代理 了,记录一下
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
点击右上角即可分享
微信分享提示