hdu 1003 Max Sum
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4
Case 2:
7 1 6
简单的动态规划,思路不好想。。
但是如果知道大体思路的话就很好理解了。。
代码:
#include<stdio.h>
#include<string.h>
int main(){
int i,n,m,j,k,t;
int num[100010];
int max;
int sum,temp,temp1,temp2,Case=1;
scanf("%d",&n);
while(n--){
memset(num,0,sizeof(num));
max=-9999;
sum=0;
temp=1;
temp1=temp2=0;
scanf("%d",&m);
for(i=1;i<=m;i++){
scanf("%d",&num[i]);
sum+=num[i];
if(sum>max)
{
max=sum; //寻找最大值
temp1=temp;
temp2=i;
}
if(sum<0){ //当结果为0时,归0,从下一个数字开始
sum=0;
temp=i+1;
}
}
printf("Case %d:\n",Case++);
printf("%d %d %d\n",max,temp1,temp2);
if(n!=0)
printf("\n");
}
return 0;
}
分类:
基础算法
【推荐】国内首个AI IDE,深度理解中文开发场景,立即下载体验Trae
【推荐】编程新体验,更懂你的AI,立即体验豆包MarsCode编程助手
【推荐】抖音旗下AI助手豆包,你的智能百科全书,全免费不限次数
【推荐】轻量又高性能的 SSH 工具 IShell:AI 加持,快人一步
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
· 终于写完轮子一部分:tcp代理 了,记录一下
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理