UVA10038

A sequence of n > 0 integers is called a jolly jumper if the absolute values of the difference between successive elements take on all the values 1 through n-1. For instance,

 

1 4 2 3
is a jolly jumper, because the absolutes differences are 3, 2, and 1 respectively. The definition implies that any sequence of a single integer is a jolly jumper. You are to write a program to determine whether or not each of a number of sequences is a jolly jumper.
Input

Each line of input contains an integer n <= 3000 followed by n integers representing the sequence.
Output
For each line of input, generate a line of output saying "Jolly" or "Not jolly".
Sample Input
4 1 4 2 3
5 1 4 2 -1 6
Sample Output
Jolly
Not jolly

#include<iostream>
using namespace std;
int a[3000];
bool con(int i,int n)
{
	i=abs(i);
	for(int j=0;j<n;++j)
	{
		if(i==a[j])
			return 1;
	}
	return 0;
}
int main()
{
	int n=0,num=0,i=0;
	while(cin>>n)
	{
		int flag=1;
		for(i=0;i<n;++i)
			cin>>a[i];
		for(i=0;i<n-1;++i)
		{
			if(!con(a[i]-a[i+1],n))
			{
				flag=0;
				break;
			}
	    }
		if(flag)
			cout<<"Jolly"<<endl;
		else
			cout<<"Not Jolly"<<endl;
	}
}

posted @ 2010-10-26 14:40  hailong  阅读(271)  评论(0编辑  收藏  举报