Monkey and Banana HDU - 1069

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food. 

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks. 

Input

The input file will contain one or more test cases. The first line of each test case contains an integer n, 
representing the number of different blocks in the following data set. The maximum value for n is 30. 
Each of the next n lines contains three integers representing the values xi, yi and zi. 
Input is terminated by a value of zero (0) for n. 


Output

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height". 
Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342


其实就是一个基础dp,但是基础十分弱的我硬是搞了俩小时……思路错了三回,心情复杂.jpg
首先把6种情况录进去之后从大到小排个序,然后从最后一个往前求当前最优解,dp思想不就是
这个意思吗……我为什么搞了俩小时……不说了,思考人生去了。

#include<bits/stdc++.h>
using namespace std;
int n;
struct node{
    int x,y,z;

}B[200];    
bool operator <(node  &a,node  &b) 
{
    if(a.x==b.x)
    return a.y>b.y;
    return a.x>b.x;
}
int dp[200];
void input()
{
    for(int i=0;i<n;i++)
    {
        int a,b,c;
        scanf("%d%d%d",&a,&b,&c);
        B[i*6+1].x=a;B[i*6+1].y=b;B[i*6+1].z=c;    
        B[i*6+2].x=a;B[i*6+2].y=c;B[i*6+2].z=b;
        B[i*6+3].x=b;B[i*6+3].y=a;B[i*6+3].z=c;
        B[i*6+4].x=b;B[i*6+4].y=c;B[i*6+4].z=a;
        B[i*6+5].x=c;B[i*6+5].y=b;B[i*6+5].z=a;
        B[i*6+6].x=c;B[i*6+6].y=a;B[i*6+6].z=b;
    }

    sort(B+1,B+n*6+1);
}
void fdp()
{
    
    memset(dp,0,sizeof(dp));
    int k=n*6;
    for(int i=0;i<k;i++) dp[i]=B[i].z;  
 
    for(int i=k-1;i>=1;i--)
    {
        for(int j=i+1;j<=k;j++)
        {        
            if(B[j].x<B[i].x&&B[j].y<B[i].y)
                if(dp[i]<dp[j]+B[i].z)
                dp[i]=dp[j]+B[i].z;    
        }    
    }

    
}
int main()
{
    int c=1;
    scanf("%d",&n);
    while(n!=0)
    {
        input();
    /*    printf("\n");
        for(int i=1;i<=6*n;i++)
        printf("%d %d %d \n",B[i].x,B[i].y,B[i].z);
        printf("\n");*/
        fdp();
        int maxn=0;
        for(int i=1;i<=n*6;i++)
        maxn=max(maxn,dp[i]);
        printf("Case %d: maximum height = %d\n",c,maxn);
        c++;
        scanf("%d",&n);
    }
    return 0;
}

 

 
posted @ 2017-08-17 11:07  时荣  阅读(147)  评论(0编辑  收藏  举报