本周作业头
问题 | 回答 |
---|---|
这个作业属于那个课程 | C语言程序设计II |
这个作业要求在哪里 | 第十一周作业 |
我在这个课程的目标是 | 掌握递归算法 |
这个作业在那个具体方面帮助我实现目标 | 递归算法 |
参考文献 | c语言程序设计 |
基础作业
6-1 计算最长的字符串长度 (15 分)
本题要求实现一个函数,用于计算有n个元素的指针数组s中最长的字符串的长度。
函数接口定义:
int max_len( char *s[], int n );
其中n个字符串存储在s[]中,函数max_len应返回其中最长字符串的长度。
裁判测试程序样例:
C
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#define MAXN 10
#define MAXS 20
int max_len( char *s[], int n );
int main()
{
int i, n;
char *string[MAXN] = {NULL};
scanf("%d", &n);
for(i = 0; i < n; i++) {
string[i] = (char *)malloc(sizeof(char)*MAXS);
scanf("%s", string[i]);
}
printf("%d\n", max_len(string, n));
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
4
blue
yellow
red
green
输出样例:
6
代码
C
int max_len( char *s[], int n )
{
int i,len[n],max=0;
for(i=0;i<n;i++){
len[i]=strlen(s[i]);
}
for(i=1;i<n;i++){
if(len[max]<len[i]){
max=i;
}
}
return len[max];
}
设计思路
运行截图
6-2 统计专业人数 (15 分)
本题要求实现一个函数,统计学生学号链表中专业为计算机的学生人数。链表结点定义如下:
struct ListNode {
char code[8];
struct ListNode *next;
};
这里学生的学号共7位数字,其中第2、3位是专业编号。计算机专业的编号为02。
函数接口定义:
int countcs( struct ListNode *head );
其中head是用户传入的学生学号链表的头指针;函数countcs统计并返回head链表中专业为计算机的学生人数。
裁判测试程序样例:
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
struct ListNode {
char code[8];
struct ListNode *next;
};
struct ListNode *createlist(); /*裁判实现,细节不表*/
int countcs( struct ListNode *head );
int main()
{
struct ListNode *head;
head = createlist();
printf("%d\n", countcs(head));
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
1021202
2022310
8102134
1030912
3110203
4021205
输出样例:
3
代码
int countcs( struct ListNode *head )
{
struct ListNode *p;
int count=0;
for(p=head;p!=NULL;p=p->next){
if(p->code[1]=='0'&&p->code[2]=='2'){
count++;
}
}
return count;
}
设计思路
遇见的问题
运行截图
6-3 删除单链表偶数节点 (20 分)
本题要求实现两个函数,分别将读入的数据存储为单链表、将链表中偶数值的结点删除。链表结点定义如下:
struct ListNode {
int data;
struct ListNode *next;
};
函数接口定义:
struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );
函数createlist从标准输入读入一系列正整数,按照读入顺序建立单链表。当读到−1时表示输入结束,函数应返回指向单链表头结点的指针。
函数deleteeven将单链表head中偶数值的结点删除,返回结果链表的头指针。
裁判测试程序样例:
#include <stdio.h>
#include <stdlib.h>
struct ListNode {
int data;
struct ListNode *next;
};
struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );
void printlist( struct ListNode *head )
{
struct ListNode *p = head;
while (p) {
printf("%d ", p->data);
p = p->next;
}
printf("\n");
}
int main()
{
struct ListNode *head;
head = createlist();
head = deleteeven(head);
printlist(head);
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
1 2 2 3 4 5 6 7 -1
输出样例:
1 3 5 7
代码
struct ListNode *createlist()
{
struct ListNode *p,*head,*p1;
int num;
int size=sizeof(struct ListNode);
p=head=p1=NULL;
scanf("%d",&num);
while(num!=-1){
p=(struct ListNode *)malloc(size);
p->data=num;
p->next=NULL;
if(head==NULL){
head=p;
}
else{
p1->next=p;
}
p1=p;
scanf("%d",&num);
}
return head;
}
struct ListNode *deleteeven( struct ListNode *head )
{
struct ListNode *p1,*p2;
p2=head;
while(p2!=NULL){
if(p2->data%2==0){
if(p2==head){
head=head->next;
free(p2);
}
else{
p1->next=p2->next;
free(p2);
}
}
else{
p1=p2;
}
p2=p2->next;
}
return head;
}
设计思路
遇见的问题
连接有问题,在编译选项中吧连接器里产生调试信息后一项改为yes就可以了
运行截图
学习时间
预习作业
准备阶段,还在思考中 ,暂无
学习感悟
思维能力不够,要多加强练习
结对优缺点
提高学习了效率,学习了更多的解决办法,有效的吸收知识