HDU - 3572 Task Schedule

Our geometry princess XMM has stoped her study in computational geometry to concentrate on her newly opened factory. Her factory has introduced M new machines in order to process the coming N tasks. For the i-th task, the factory has to start processing it at or after day Si, process it for Pi days, and finish the task before or at day Ei. A machine can only work on one task at a time, and each task can be processed by at most one machine at a time. However, a task can be interrupted and processed on different machines on different days. 
Now she wonders whether he has a feasible schedule to finish all the tasks in time. She turns to you for help. 

InputOn the first line comes an integer T(T<=20), indicating the number of test cases. 

You are given two integer N(N<=500) and M(M<=200) on the first line of each test case. Then on each of next N lines are three integers Pi, Si and Ei (1<=Pi, Si, Ei<=500), which have the meaning described in the description. It is guaranteed that in a feasible schedule every task that can be finished will be done before or at its end day. 
OutputFor each test case, print “Case x: ” first, where x is the case number. If there exists a feasible schedule to finish all the tasks, print “Yes”, otherwise print “No”. 

Print a blank line after each test case. 
Sample Input

2
4 3
1 3 5 
1 1 4
2 3 7
3 5 9

2 2
2 1 3
1 2 2

Sample Output

Case 1: Yes
   
Case 2: Yes

题意:
有m台机器,n个任务,每个任务需要p天完成,任务开始日期s,结束日期t,中间可以间断,但是每天每台机器只能进行一件任务。问能否按要求完成任务。
解法:
网络流
从源点向每一个任务节点连接一条容量为p的边,从每一个任务节点向每天连接一个容量为1的边,日期的节点向汇点连接一条容量为5的边,跑一遍最大流看流量是否为每件任务每台机器需要的时间和。
代码:
#include <bits/stdc++.h>
using namespace std;
int ii=0;
#define N 1010
#define M 320010
#define ll int
#define inf 100000000
inline ll Max(ll a,ll b) {
	return a>b?a:b;
}
inline ll Min(ll a,ll b){
	return a<b?a:b;
}
struct Edge{
	int from,to,flow,cap,nex;
}edge[M*2+10];
int head[N],edgenum;
void init(){
	memset(head,-1,sizeof(head));
	edgenum=0;
}
void addedge(int u,int v,int cap){
	Edge E={u,v,0,cap,head[u]};
	edge[edgenum]=E;
	head[u]=edgenum++;
	Edge E2={v,u,0,0,head[v]};
	edge[edgenum]=E2;
	head[v]=edgenum++;
}
int dis[N],cur[N];
bool vis[N];
bool BFS(int Start,int End){
	memset(vis,0,sizeof(vis));
	memset(dis,-1,sizeof(dis));
	queue<int> Q;
	while(!Q.empty()) Q.pop();
	Q.push(Start);
	dis[Start]=0;vis[Start]=1;
	while(!Q.empty()){
		int u=Q.front();
		Q.pop();
	//	cout<<u<<endl;
		for (int i=head[u];i!=-1;i=edge[i].nex){
			Edge E=edge[i];
	//		cout<<"\t"<<E.to<<" "<<E.cap<<" "<<E.flow<<endl;
			if (!vis[E.to]&&E.cap>E.flow){
				vis[E.to]=1;
				dis[E.to]=dis[u]+1;
				if (E.to==End) return true;
				Q.push(E.to);
			}
		}
	}
	return false;
}
int DFS(int x,int a,int End){
	if (x==End||a==0) return a;
	int flow=0,f;
	for (int &i=cur[x];i!=-1;i=edge[i].nex){
		Edge &E=edge[i];
		if (dis[x]+1==dis[E.to]&&(f=DFS(E.to,Min(a,E.cap-E.flow),End))>0){
			E.flow+=f;
			edge[i^1].flow-=f;
			flow+=f;
			a-=f;
			if (a==0) break;
		}
	}
	return flow;
}
int Maxflow(int Start,int End){
	int flow=0;
	while(BFS(Start,End)){
		memcpy(cur,head,sizeof(head));
		flow+=DFS(Start,inf,End);
	}
	return flow;
}
void deal(){
	init();
	ii++;
	int n,m;
	scanf("%d%d",&n,&m);
	int start,end;
	start=0;
	int p,s,t;
	int ans=0;
	int maxt=0;
	for (int i=1;i<=n;i++){
		scanf("%d%d%d",&p,&s,&t);
		addedge(0,i,p);
		ans+=p;
		for (int j=s;j<=t;j++){
			addedge(i,j+n,1);
		}
		if (t>maxt) maxt=t;
	}
	for (int i=1;i<=maxt;i++){
		addedge(n+i,n+maxt+1,m);
	}
	int flow=Maxflow(0,n+maxt+1);
	printf("Case %d: ",ii);
//	cout<<"ans: "<<flow<<endl;
	if (flow==ans){
		printf("Yes");
	}else{
		printf("No");
	}
	printf("\n\n");
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--) 
		deal();
    return 0;
}

  

posted @ 2017-10-23 17:02  晓风微微  阅读(171)  评论(0编辑  收藏  举报