HDU - 2594 Simpsons’ Hidden Talents

题目:

Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had. 
Marge: Yeah, what is it? 
Homer: Take me for example. I want to find out if I have a talent in politics, OK? 
Marge: OK. 
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix 
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton 
Marge: Why on earth choose the longest prefix that is a suffix??? 
Homer: Well, our talents are deeply hidden within ourselves, Marge. 
Marge: So how close are you? 
Homer: 0! 
Marge: I’m not surprised. 
Homer: But you know, you must have some real math talent hidden deep in you. 
Marge: How come? 
Homer: Riemann and Marjorie gives 3!!! 
Marge: Who the heck is Riemann? 
Homer: Never mind. 
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.

InputInput consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.OutputOutput consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0. 
The lengths of s1 and s2 will be at most 50000.Sample Input

clinton
homer
riemann
marjorie

Sample Output

0
rie 3


题意:
求s1的前缀和s2的后缀的最长公共串的长度。
做法:
1.KMP,两个串和在一起,最后一个next的值就是答案
2.hash,我是用字符串hash写的,很好实现。
代码:
#include<iostream>
using namespace std;
#include<cstdio>
#include<cstring>
const unsigned long long seed=13331;
const int maxn=110000;
typedef unsigned long long ull;
ull base[maxn];
ull p1[maxn],p2[maxn]; 
void init(){
	base[0]=1;
	for (int i=1;i<maxn;i++) base[i]=base[i-1]*seed; 
}
int jx=1;
char s1[maxn],s2[maxn];
void inithash(char s[],ull h[],int n){
	h[0]=0;
	for (int i=1;i<=n;i++) h[i]=h[i-1]*seed+s[i-1]-'a'+1;
//	for (int i=1;i<=n;i++) cout<<h[i]<<endl;
}
ull gethash(int l,int r,ull h[]){
	return h[r]-h[l-1]*base[r-l+1];
}
void deal(){
	if (scanf("%s",s1)==EOF){
		jx=0;return;
	}
	int n=strlen(s1);
	scanf("%s",s2);
	int m=strlen(s2);
	inithash(s1,p1,n);
	inithash(s2,p2,m);
	int mn=min(n,m);
	int ans=0;
	for (int i=mn;i>=1;i--){
		ull ss1=gethash(1,i,p1),ss2=gethash(m-i+1,m,p2);
//		cout<<i<<" "<<ss1<<" "<<ss2<<endl;
		if (ss1==ss2) {
			ans=i;
			break;
		}
	}
	if (ans>0){
		for (int i=0;i<ans;i++) putchar(s1[i]);
		putchar(' ');
	}
	printf("%d\n",ans);
}
int main(){
	init();
	while (jx) deal();
	return 0;
}

  

posted @ 2017-10-21 21:01  晓风微微  阅读(186)  评论(0编辑  收藏  举报