HDU - 3746 Cyclic Nacklace

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task. 

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2: 
Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden. 
CC is satisfied with his ideas and ask you for help.InputThe first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases. 
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).OutputFor each case, you are required to output the minimum count of pearls added to make a CharmBracelet.Sample Input

3
aaa
abca
abcde

Sample Output

0
2
5
做法:
要求出其到最后的循环节长度,就要求出其next数组,求出到最后一位时的最长相同的前缀,这样总长度-最后相同的长度就是循环节的长度,这样如果他与总长度相同那么答案就是总长度,否则如果总长度%循环节==0那
么答案就是0,因为恰好为满的循环,否则就输出循环节长度-到最后一位在循环节第几位,最后一位在循环节第几位可以用最后一位时的最长前缀%循环节长度得出。
代码:
#include<iostream>
using namespace std;
#include<cstdio>
#include<cstring>
#include<ctime>
#include<cstdlib>
const int maxn=101000;
int nextp[maxn];
char s[maxn];
int getnext(){
	nextp[0]=nextp[1]=0;
	int zans=1e5;
	int i,j;
	for (i=1;s[i]!='\0';i++){
		j=i;
		while(j>0){
			j=nextp[j];
			if (s[j]==s[i]) break;
		}
		if (s[j]==s[i]){
			nextp[i+1]=j+1;
		}
		else nextp[i+1]=0;
	}
	int tmp=nextp[i];
	int l=i-tmp;
	if (i%l==0&&l!=i) return 0;
	else
	return l-tmp%l;
}
void deal(){
	scanf("%s",s);
	int ans=getnext();
	printf("%d\n",ans);
}
int main(){
	int t;
	scanf("%d",&t);
	while(t--) deal();
	return 0;
}

  

posted @ 2017-10-19 22:45  晓风微微  阅读(132)  评论(0编辑  收藏  举报