HDU - 3336 Count the string

题目:

It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example: 
s: "abab" 
The prefixes are: "a", "ab", "aba", "abab" 
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6. 
The answer may be very large, so output the answer mod 10007.InputThe first line is a single integer T, indicating the number of test cases. 
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.OutputFor each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.Sample Input

2
4
abab 
8
abababab
 

Sample Output

6 
20


题意:
给一个字符串,问所有前缀在字符串中出现次数的和是多少?
解法:
KMP+DP
求出next数组之后,得到一个位置的上一个匹配位置,然后做DP即可。
代码:
#include<iostream>
using namespace std;
#include<cstring>
#include<cstdio>
#define maxn 210000
int nextp[maxn];
char s[maxn];
int f[maxn];
const int mod=10007;
int pre[maxn];
int getnext(char s[],int nextp[],int n){
    nextp[0]=0;nextp[1]=0;
    for (int i=0;i<n;i++) f[i]=1,pre[i]=-1;
    for (int i=1;i<=n;i++){
        int j=i;
        while(j>0){
            j=nextp[j];
            if (s[j]==s[i]) break;
        }
        if(s[j]==s[i]) {
        nextp[i+1]=j+1;
        pre[i]=j;
        }
        else
        nextp[i+1]=j;
    }
    int zans=0;
    for (int i=n-1;i>=0;i--){
        zans=zans%mod+f[i]%mod;
        zans%=mod;
        if (pre[i]==-1) continue;
        f[pre[i]]+=f[i];
    }
    return zans;
}
void deal(){
    int n;
    scanf("%d",&n);
    scanf("%s",&s);
    int ans;
    ans=getnext(s,nextp,n);
    printf("%d\n",ans);
}
int main(){
    int t;
    scanf("%d",&t);
    while(t--) deal();
    return 0;    
}

 

posted @ 2017-10-19 21:03  晓风微微  阅读(134)  评论(0编辑  收藏  举报