POJ - 3261 Milk Patterns 后缀数组

题目:

Milk Patterns
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 16482   Accepted: 7283
Case Time Limit: 2000MS

Description

Farmer John has noticed that the quality of milk given by his cows varies from day to day. On further investigation, he discovered that although he can't predict the quality of milk from one day to the next, there are some regular patterns in the daily milk quality.

To perform a rigorous study, he has invented a complex classification scheme by which each milk sample is recorded as an integer between 0 and 1,000,000 inclusive, and has recorded data from a single cow over N (1 ≤ N ≤ 20,000) days. He wishes to find the longest pattern of samples which repeats identically at least K (2 ≤ KN) times. This may include overlapping patterns -- 1 2 3 2 3 2 3 1 repeats 2 3 2 3 twice, for example.

Help Farmer John by finding the longest repeating subsequence in the sequence of samples. It is guaranteed that at least one subsequence is repeated at least K times.

Input

Line 1: Two space-separated integers: N and K
Lines 2..N+1: N integers, one per line, the quality of the milk on day i appears on the ith line.

Output

Line 1: One integer, the length of the longest pattern which occurs at least K times

Sample Input

8 2
1
2
3
2
3
2
3
1

Sample Output

4

Source

 
翻译:(from bzoj-1717)
农夫John发现他的奶牛产奶的质量一直在变动。经过细致的调查,他发现:虽然他不能预见明天 产奶的质量,但连续的若干天的质量有很多重叠。我们称之为一个“模式”。 John的牛奶按质量可以被赋予一个0到1000000之间的数。并且John记录了N(1<=N<=20000)天的 牛奶质量值。他想知道最长的出现了至少K(2<=K<=N)次的模式的长度。 比如1 2 3 2 3 2 3 1 中 2 3 2 3出现了两次。当K=2时,这个长度为4。
Input
* Line 1: 两个整数 N,K。 * Lines 2..N+1: 每行一个整数表示当天的质量值。
Output
* Line 1: 一个整数:N天中最长的出现了至少K次的模式的长度
 
分析:
后缀数组的height[i]储存的是字典序排名为i的串和字典序排名位i-1的串的最长公共前缀。
那么我们二分答案d,检测是否有连续k-1个height元素>d即可。
 
代码:
#pragma warning(disable:4786)
#pragma comment(linker, "/STACK:102400000,102400000")
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<stack>
#include<queue>
#include<map>
#include<set>
#include<vector>
#include<cmath>
#include<string>
#include<sstream>
#define LL long long
#define FOR(i,f_start,f_end) for(int i=f_start;i<=f_end;++i)
#define mem(a,x) memset(a,x,sizeof(a))
#define lson l,m,x<<1
#define rson m+1,r,x<<1|1
using namespace std;
const int INF = 0x3f3f3f3f;
const int mod = 1e9 + 7;
const double PI = acos(-1.0);
const double eps = 1e-8;
const int maxn = 3e4 + 5;
const int maxs = 30;
int s[maxn];
int sa[maxn], t[maxn], t2[maxn], c[maxn], n , m;
int d[maxn][maxs];
int height[maxn], rank[maxn];
void build_sa(int m)
{
	int i, *x = t, *y = t2;
	for ( i = 0; i < m; i++)		c[i] = 0;
	for ( i = 0; i < n; i++)		c[x[i] = s[i]]++;
	for ( i = 1; i < m; i++)	c[i] += c[i - 1];
	for (i = n - 1; i >= 0; i--)	sa[--c[x[i]]] = i;
	for (int k = 1; k <= n; k <<= 1){
		int p = 0;
		for (i = n - 1; i >= n-k; i--)
			y[p++] = i;
		for (i = 0; i < n; i++){
			if (sa[i] >= k)
				y[p++] = sa[i] - k;
		}
		for (i = 0; i < m; i++)	c[i] = 0;
		for (i = 0; i < n; i++)
			c[x[y[i]]]++;
		for (i = 0; i < m; i++)
			c[i] += c[i - 1];
		for (i = n - 1; i >= 0; i--)
			sa[--c[x[y[i]]]] = y[i];
		swap(x, y);
		p = 1;	x[sa[0]] = 0;
		for (i = 1; i < n; i++){
			x[sa[i]] = y[sa[i - 1]] == y[sa[i]] && y[sa[i - 1] + k] == y[sa[i] + k] ? p - 1 : p++;
		}
		if (p >= n)	break;
		m = p;
	}
}
void getHeight()
{
	int i, j, k = 0;
	for (i = 0; i < n; i++)	rank[sa[i]] = i;
	for (i = 0; i < n; i++){
		if (k)	k--;
		 j = sa[rank[i] - 1];
		while (s[i + k] == s[j + k])	k++;
		height[rank[i]] = k;
	}
}
void RMQ_init()
{
    for(int i = 0 ; i<n; i++)       d[i][0] = sa[i];
    for(int j = 1 ; (1<<j) - 1 <=n ; j++){
        for(int i = 0 ; i + (1<<j) - 1 < n ; i++){
            d[i][j] = min(d[i][j-1] , d[i + (1<< (j - 1))][ j -1 ]);
        }
    }
}
int RMQ(int L , int R)
{
    int k = 0;
    while((1<<(k + 1)) <= R - L + 1)    k++;
    return min(d[L][k] , d[R - (1 << k) + 1][k]);
}
int k;
int check(int d){
    int l=0;
    for (int i=1;i<n;i++){
        if (height[i]>=d){
            if (l==0) l=2;
            else l++;
        }else{
        l=0;
        }
        if (l>=k) return 1;
    }
    return 0;
}
int main()
{
    while(scanf("%d%d",&n,&k)!=EOF){
        int maxm=0,p;
        for (int i=1;i<=n;i++){
            scanf("%d",&p);
            s[i-1]=p;
            if (p>maxm) maxm=p;
        }
        build_sa(maxm+1);
        getHeight();
        int l=0,r=n;
        int m=(l+r)/2;
        int zans=0;
        while(l<=r){
            m=(l+r)/2;
            int ans=check(m);
            if (ans) l=m+1,zans=m;
            else
            r=m-1;
        }
        printf("%d\n",zans);
    }
}

 

posted @ 2017-10-06 16:29  晓风微微  阅读(206)  评论(0编辑  收藏  举报