hdu 1052 Tian Ji -- The Horse Racing

Tian Ji -- The Horse Racing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17682    Accepted Submission(s): 5131


Problem Description
Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"



Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.
 

Input
The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.
 

Output
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.
 

Sample Input
3 92 83 71 95 87 74 2 20 20 20 20 2 20 19 22 18 0
 

Sample Output
200 0 0
 

题意:田忌赛马。田忌和齐王各有n匹马。输入田忌的马的速度和齐王的马的速度。每一轮田忌赢了就得200两银子,平就得0两,输了就失去200两银子。问田忌最多能得到多少。

思路:每次取田忌的最快的马与国王最快的马比較,有三种情况。
一,田忌最快的马比国王最快的马快,那么直接拿田忌最快的马去赢国王最快的马。


二。田忌最快的马比国王最快的马慢,那么拿田忌最慢的马去输国王最快的马。
三,田忌最快的马与国王最快的马速度一样。
       1).先拿田忌最慢的马与国王最慢的马比較。


             若田忌比国王快,直接赢掉国王最慢的马。
             否则 田忌最慢的马再去与国王最快的马比。
       2).假设最快最慢的马都一样,用田忌最慢的马和国王最快的马比。


代码:
<span style="font-size:18px;">#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
int a[1005],b[1005],c[1005];
bool cmp(int x,int y)
{
	return (x>y);
}

int main ()
{
	int n;
	int i,sum;
    int front,head;
	int rear,tail;
	while(~scanf("%d",&n)&&n)
	{
		sum=0;
		for(i=0;i<n;i++)
			scanf("%d",&a[i]);
		for(i=0;i<n;i++)
			scanf("%d",&b[i]);
		
		sort(a,a+n,cmp);   // 从大到小排序
		sort(b,b+n,cmp);

        front=head=0;
		rear=tail=n-1;

		while(front<=rear)
		{
			if(a[front]>b[head])   // 假设田忌最快的马比国王最快的马快
			{
				c[front]=head;     //则直接拿田忌最快的马去赢国王最快的马
				front++;
				head++;
			}
			else
				if(a[front]<b[head])    // 假设田忌最快的马比国王最快的马慢
				{
					c[rear]=head;       //则拿田忌最慢的马去输国王最快的马
					rear--;
					head++;
				}
				else                     // 假设田忌最快的马比国王最快的马速度一样
					if(a[rear]>b[tail])   // 假设田忌最慢的马比国王最慢的马快
					{
						c[rear]=tail;    //则拿田忌最慢的马去赢国王最慢的马
						rear--;
						tail--;
					}
					else               // 假设田忌最慢的马比国王最慢的马速度一样
					{
						c[rear]=head;    //则拿田忌最慢的马去输国王最快的马
						rear--;
						head++;
					}
		}

		for(i=0;i<n;i++)   
		{
			if(a[i]>b[c[i]])
				sum++;
			if(a[i]<b[c[i]])
				sum--;
		}
		printf("%d\n",sum*200);
	}
	return 0;
}</span>

比如:

安排之前数组情况:
田忌:92 83 71
齐王:95 87 74

安排之后数组情况:
田忌:92 83 71
齐王:87 74 95


posted on 2019-05-03 17:46  xfgnongmin  阅读(109)  评论(0编辑  收藏  举报

导航