*点击

[USACO14DEC] Guard Mark G

题目

Description

FJ将飞盘抛向身高为H(1 <= H <= 1,000,000,000)的Mark,但是Mark被N(2 <= N <= 20)头牛包围。牛们可以叠成一个牛塔,如果叠好后的高度大于或者等于Mark的高度,那牛们将抢到飞盘。

每头牛都一个身高,体重和耐力值三个指标。耐力指的是一头牛最大能承受的叠在他上方的牛的重量和。请计算牛们是否能够抢到飞盘。若是可以,请计算牛塔的最大稳定强度,稳定强度是指,在每头牛的耐力都可以承受的前提下,还能够在牛塔最上方添加的最大重量。

Input

The first line of input contains N and H.

The next N lines of input each describe a cow, giving its height,weight, and strength. All are positive integers at most 1 billion.

Output

If Bessie's team can build a stack tall enough to catch the frisbee, please output the maximum achievable safety factor for such a stack.

Otherwise output "Mark is too tall" (without the quotes).

Sample Input

4 10 
9 4 1 
3 3 5 
5 5 10 
4 4 5 

Sample Output

2 

思路

一道状压$dp$的题;

用一个数组$H$记录当前状态的高度,一个数组$dp$记录当前状态可承受最大的重量即可;

那么状态转移方程就为:

$dp[k]=max(dp[k],min(s[i],dp[k^(1<<(i-1))]-w[i]));$

$H[k]=H[k^(1<<(i-1))]+h[i];$

$i$表示此时最上面的牛,$k$表示此时牛塔的状态;

 


 

代码

#include<bits/stdc++.h>
typedef long long ll;
using namespace std;
const ll _=21;
ll n,m;
ll h[_],w[_],s[_];
ll dp[1<<20],H[1<<20];
int main()
{
    scanf("%lld%lld",&n,&m);
    for(ll i=1;i<=n;i++)
        scanf("%lld%lld%lld",&h[i],&w[i],&s[i]);
    dp[0]=INT_MAX;//没有牛时承重为无穷
    ll ans=0;
    for(ll k=1;k<=(1<<n)-1;k++)
    for(ll i=1;i<=n;i++)
    if(k&(1<<(i-1)))
    {
        if(dp[k^(1<<(i-1))]<w[i]) continue;//保证如果不超过下面牛的承重范围
        dp[k]=max(dp[k],min(s[i],dp[k^(1<<(i-1))]-w[i]));//记录最大承受重量
        H[k]=H[k^(1<<(i-1))]+h[i];//记录当前状态的高度
        if(H[k]>=m)//高度超过mark,就记录答案
            ans=max(ans,dp[k]);
    }
    if(!ans)
    {
        printf("Mark is too tall");
        return 0;
    }
    printf("%lld",ans);
    return 0;
}

 

 

 

 

 

 

 

 

 

posted @ 2024-12-19 22:52  木偶人-怪咖  阅读(3)  评论(0编辑  收藏  举报
*访客位置3D地图 *目录