Odd Sum 

Given a range [a, b], you are to find the summation of all the odd integers in this range. For example, the summation of all the odd integers in the range [3, 9] is 3 + 5 + 7 + 9 = 24.

Input 

There can be at multiple test cases. The first line of input gives you the number of test cases, T ( 1$ \le$T$ \le$100). Then T test cases follow. Each test case consists of 2 integers a and b ( 0$ \le$a$ \le$b$ \le$100) in two separate lines.

Output 

For each test case you are to print one line of output - the serial number of the test case followed by the summation of the odd integers in the range [a, b].

Sample Input 

2
1
5
3
5

Sample Output 

Case 1: 9
Case 2: 8

 


Miguel Revilla 2004-12-02
#include"stdio.h"
#include"stdlib.h"
int main()
{   long n,a,b,t,i,s;
    scanf("%ld",&n);
    t=0;
    while(n--)
    {scanf("%ld",&a); 
     scanf("%ld",&b);
     s=0;
     for(i=a;i<=b;i++)//判断是否为奇数; 
      {if(i%2!=0)
       s+=i;
       }
     t++;//t表示case,在每一次情况结束后加一;  
     printf("Case %ld: %ld\n",t,s);
     }
 system("pause");
 return 0;     
} 

 

posted on 2013-02-21 11:39  LOVE小熊ing  阅读(191)  评论(0编辑  收藏  举报