POJ 3660 Cow Contest【传递闭包】

解题思路:给出n头牛,和这n头牛之间的m场比赛结果,问最后能知道多少头牛的排名。 首先考虑排名怎么想,如果知道一头牛打败了a头牛,以及b头牛打赢了这头牛,那么当且仅当a+b+1=n时可以知道排名,即为此时该牛排第b+1名。

即推出当一个点的出度和入度的和等于n-1的时候,该点的排名是可以确定的, 即用传递闭包来求两点的连通性,如果d[i][j]==1,那么表示i,j两点相连通,度数都分别加1

 

Cow Contest
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7262   Accepted: 4020

Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ AN; 1 ≤ BN; AB), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M * Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined  

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2
#include<iostream>  
#include<cstdio>  
#include<cstring>  
#include<algorithm>  
using namespace std;
int d[105][105],degree[105];
int main()
{
	int n,m,i,j,k,ans=0,u,v;
	while(scanf("%d %d",&n,&m)!=EOF)
	{
		memset(degree,0,sizeof(degree));
		memset(d,0,sizeof(d));
	
	for(i=1;i<=m;i++)
	{
		scanf("%d %d",&u,&v);
		d[u][v]=1;
	}
	
	for(k=1;k<=n;k++)
	for(i=1;i<=n;i++)
	for(j=1;j<=n;j++)
	d[i][j]=d[i][j]||(d[i][k]&&d[k][j]);
	
	for(i=1;i<=n;i++)
	{
		for(j=1;j<=n;j++)
	    {
				if(d[i][j])
			{
				degree[i]++;
				degree[j]++;
			}
		}		
	}
	for(i=1;i<=n;i++)
	if(degree[i]==n-1)
	ans++;
	printf("%d\n",ans);	
	}
}

  

posted @ 2015-01-28 00:26  sequenceaa  阅读(162)  评论(0编辑  收藏  举报