树形dp入门题目
Strategic game
Time Limit:2000MS Memory Limit:65536K
Total Submit:33 Accepted:15
Description
Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?
Your program should find the minimum number of soldiers that Bob has to put for a given tree.
For example for the tree:
the solution is one soldier ( at the node 1).
Input
The input contains several data sets in text format. Each data set represents a tree with the following description:
- the number of nodes
- the description of each node in the following format
node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifiernumber_of_roads
or
node_identifier:(0)
The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500);the number_of_roads in each line of input will no more than 10. Every edge appears only once in the input data.
Output
The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following:
Sample Input
4 0:(1) 1 1:(2) 2 3 2:(0) 3:(0) 5 3:(3) 1 4 2 1:(1) 0 2:(0) 0:(0) 4:(0)
Sample Output
1 2
Source
Southeastern Europe 2000
其实也可以用最小点覆盖来做,都很简单啦~
ans[i][0]表示在不选择节点i的情况下,以i为根节点的子树,最少需要选择的点数;
ans[i][1]表示在选择节点i的情况下,以i为根节点的子树,最少需要选择的点数;
当i是叶子时,ans[i][0]=0,ans[i][1]=1;
else
ans[i][0]=sigma(ans[j][1])(j为i的子节点)
ans[i][1]=1+sigmamin(ans[j][0],ans[j][1]);
#include<stdio.h>
#include<string.h>
#define min(a,b) a<b?a:b
int ans[1505][2];
int child[1505];
int pos[1505];
struct EDGE{
int from,to;
}edge[1505];
void treedp(int st)
{
int to;
ans[st][0]=0;ans[st][1]=1;
if(child[st]==0) return ;
int i=pos[st];
while(edge[i].from==st)
{
to=edge[i++].to;
treedp(to);
ans[st][1]+=min(ans[to][0],ans[to][1]);
ans[st][0]+=ans[to][1];
}
}
int main()
{
// freopen("in.txt","r",stdin);
// freopen("out.txt","w",stdout);
int tot;
int i,j,s,t,sum,num,leve;
while(~scanf("%d",&tot))
{
int count=1;
sum=leve=0;
for(i=1;i<=tot;i++)
{
scanf("%d:(%d)",&s,&num);
sum+=s;
pos[s]=count;
child[s]=num;
for(j=1;j<=num;j++)
{
scanf("%d",&t);
leve+=t;
edge[count].from=s;
edge[count++].to=t;
}
}
int root=sum-leve;
treedp(root);
printf("%d\n",min(ans[root][0],ans[root][1]));
}
return 0;
}