poj 2566 Bound Found

Bound Found
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 4384   Accepted: 1377   Special Judge

Description

Signals of most probably extra-terrestrial origin have been received and digitalized by The Aeronautic and Space Administration (that must be going through a defiant phase: "But I want to use feet, not meters!"). Each signal seems to come in two parts: a sequence of n integer values and a non-negative integer t. We'll not go into details, but researchers found out that a signal encodes two integer values. These can be found as the lower and upper bound of a subrange of the sequence whose absolute value of its sum is closest to t. 

You are given the sequence of n integers and the non-negative target t. You are to find a non-empty range of the sequence (i.e. a continuous subsequence) and output its lower index l and its upper index u. The absolute value of the sum of the values of the sequence from the l-th to the u-th element (inclusive) must be at least as close to t as the absolute value of the sum of any other non-empty range.

Input

The input file contains several test cases. Each test case starts with two numbers n and k. Input is terminated by n=k=0. Otherwise, 1<=n<=100000 and there follow n integers with absolute values <=10000 which constitute the sequence. Then follow k queries for this sequence. Each query is a target t with 0<=t<=1000000000.

Output

For each query output 3 numbers on a line: some closest absolute sum and the lower and upper indices of some range where this absolute sum is achieved. Possible indices start with 1 and go up to n.

Sample Input

5 1
-10 -5 0 5 10
3
10 2
-9 8 -7 6 -5 4 -3 2 -1 0
5 11
15 2
-1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1
15 100
0 0

Sample Output

5 4 4
5 2 8
9 1 1
15 1 15
15 1 15

Source

/*
* @Author: Lyucheng
* @Date:   2017-08-02 10:22:54
* @Last Modified by:   Lyucheng
* @Last Modified time: 2017-08-02 15:57:35
*/
/*
 题意;给你一个序列,然后有k次查询,让你找一个子序列绝对值最接近t的序列

 思路:尺取,如果想要使用尺取,要保证数列的单调性,但是序列中有负数,要给前缀排序
*/
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <time.h>

#define MAXN 100005
#define INF 2147483640
using namespace std;

struct Node{
    int id;
    int val;
    bool operator < (const Node & other) const {
        return val<other.val;
    }
}node[MAXN];
int n,k;
int t;
int a;
int l,r;
int res_l,res_r;
int res;
int _min;

int main(){
    // freopen("in.txt", "r", stdin);
    // freopen("out.txt", "w", stdout);
    while(scanf("%d%d",&n,&k)!=EOF){
        node[0].id=0;
        node[0].val=0;
        for(int i=1;i<=n;i++){
            scanf("%d",&a);
            node[i].val=node[i-1].val+a;
            node[i].id=i;
        }
        sort(node,node+n+1);
        while(k--){
            scanf("%d",&t);
            l=0,r=1;
            _min=INF;
            while(r<=n&&_min){
                int pos=abs(node[r].val-node[l].val);
                if(abs(pos-t)<=_min){
                    _min=abs(pos-t);
                    res=pos;
                    res_l=node[l].id;
                    res_r=node[r].id;
                }
                if (pos<t) r++; 
                if (pos>t) l++;
                if (l==r) r++;
            }
            if(res_l>res_r) swap(res_l,res_r);
            printf("%d %d %d\n",res,res_l+1,res_r);
        }
    }
    return 0;
}

 

posted @ 2017-08-02 15:59  勿忘初心0924  阅读(141)  评论(0编辑  收藏  举报