ZOJ 3777-Problem Arrangement(状压DP)

B - Problem Arrangement
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

The 11th Zhejiang Provincial Collegiate Programming Contest is coming! As a problem setter, Edward is going to arrange the order of the problems. As we know, the arrangement will have a great effect on the result of the contest. For example, it will take more time to finish the first problem if the easiest problem hides in the middle of the problem list.

There are N problems in the contest. Certainly, it's not interesting if the problems are sorted in the order of increasing difficulty. Edward decides to arrange the problems in a different way. After a careful study, he found out that the i-th problem placed in the j-th position will add Pij points of "interesting value" to the contest.

Edward wrote a program which can generate a random permutation of the problems. If the total interesting value of a permutation is larger than or equal to M points, the permutation is acceptable. Edward wants to know the expected times of generation needed to obtain the first acceptable permutation.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains two integers N (1 <= N <= 12) and M (1 <= M <= 500).

The next N lines, each line contains N integers. The j-th integer in the i-th line is Pij (0 <= Pij <= 100).

Output

For each test case, output the expected times in the form of irreducible fraction. An irreducible fraction is a fraction in which the numerator and denominator are positive integers and have no other common divisors than 1. If it is impossible to get an acceptable permutation, output "No solution" instead.

Sample Input

2
3 10
2 4 1
3 2 2
4 5 3
2 6
1 3
2 4

Sample Output

3/1
No solution
#include <bits/stdc++.h>
using namespace std;
int t;
int n,m;
int a[15][15];
int dp[(1<<13)][510];//表示i种状态,获取j的快乐度的方案数
int f[15];
void init(){
    memset(dp,0,sizeof dp);
}
int main(){
    // freopen("in.txt","r",stdin);
    f[0]=1;
    for(int i=1;i<=13;i++){
        f[i]=f[i-1]*i;
    }
    scanf("%d",&t);
    while(t--){
        init();
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++){
                scanf("%d",&a[i][j]);
            }
        }
        dp[0][0]=1;
        int tol=(1<<n);
        for(int i=0;i<=tol;i++){//枚举状态
            int tmp=0;
            for(int j=1;j<=n;j++){
                if( ( i&(1<<(j-1)) ) ) 
                    tmp++;
            }
            for(int j=1;j<=n;j++){
                if(( i&(1<<(j-1)) )==0)
                for(int k=0;k<=m;k++){
                    if(k+a[tmp+1][j]>=m){
                        dp[i+(1<<(j-1))][m]+=dp[i][k];
                    }else{
                        dp[i+(1<<(j-1))][k+a[tmp+1][j]]+=dp[i][k];
                    }
                }
            }
        }
        if(dp[tol-1][m]==0){
            puts("No solution");
        }else{
            int res=__gcd(f[n],dp[tol-1][m]);
            printf("%d/%d\n",f[n]/res,dp[tol-1][m]/res);
        }
    }
    return 0;
}

 

posted @ 2017-04-09 11:16  勿忘初心0924  阅读(409)  评论(0编辑  收藏  举报