Picture

Picture

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 72 Accepted Submission(s): 59
 
Problem Description
Give you the width and height of the rectangle,darw it.
 
Input
Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.
 
Output
For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line.
 
Sample Input
3 2
 
Sample Output
+---+
|   |
|   |
+---+
 
Author
xhd
 
Source
校庆杯Warm Up
 
Recommend
linle
 
/*
题意:画一个n*m的小盒子

初步思路:略
*/
#include<bits/stdc++.h>
using namespace std;
int n,m;
int main(){
    // freopen("in.txt","r",stdin);
    while(scanf("%d%d",&n,&m)!=EOF){
        printf("+");
        for(int i=0;i<n;i++) printf("-");
        printf("+\n");
        for(int i=0;i<m;i++){
            printf("|");
            for(int j=0;j<n;j++){
                printf(" ");
            }
            printf("|\n");
        }
        printf("+");
        for(int i=0;i<n;i++) printf("-");
        printf("+\n\n");
    }
    return 0;
}

 

posted @ 2017-02-14 03:48  勿忘初心0924  阅读(188)  评论(0编辑  收藏  举报