hdu4393 Throw nails(只用模拟前面500来次,后面根据速度、位置、id值排序即可)

                                                                                                              Throw nails
The annual school bicycle contest started. ZL is a student in this school. He is so boring because he can't ride a bike!! So he decided to interfere with the contest. He has got the players' information by previous contest video. A player can run F meters the first second, and then can run S meters every second.  Each player has a single straight runway. And ZL will throw a nail every second end to the farthest player's runway. After the "BOOM", this player will be eliminated. If more then one players are NO.1, he always choose the player who has the smallest ID.
 

Input

In the first line there is an integer T (T <= 20), indicates the number of test cases.  In each case, the first line contains one integer n (1 <= n <= 50000), which is the number of the players.  Then n lines follow, each contains two integers Fi(0 <= Fi <= 500), Si (0 < Si <= 100) of the ith player. Fi is the way can be run in first second and Si is the speed after one second .i is the player's ID start from 1. 
Hint
Huge input, scanf is recommended. 
Huge output, printf is recommended. 
 

Output

For each case, the output in the first line is "Case #c:".  c is the case number start from 1.  The second line output n number, separated by a space. The ith number is the player's ID who will be eliminated in ith second end. 
 

Sample Input

2
3
100 1
100 2
3 100
5
1 1
2 2
3 3
4 1
3 4
 

Sample Output

Case #1:
1 3 2
Case #2:
4 5 3 2 1
 
题意:有N个人跑步比赛,刚开始都有起始位置s和速度f,每秒淘汰一名选手(起始是第1秒,也算),淘汰跑在最前面的,如果有多个人跑在前面,则淘汰id值最小的。
解析:由于N很大,不可能每秒都模拟,但关注一下数据,起始位置s很小,想象一下,如果a的速度比b的速度多1,那么500+秒后不管a和b的起始位置如何,a一定在b前面。所以最多只用模拟前500秒(如果想保险,可以多加几次),如果还有剩下的选手,先按他们的速度排序,如果两个人的速度相同,则比较他们的当前的位置,否则比较id.
代码如下:
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<set>
#include<map>
#include<queue>
#include<vector>
#include<iterator>
#include<utility>
#include<sstream>
#include<iostream>
#include<cmath>
#include<stack>
using namespace std;
const int INF=1000000007;
const double eps=0.00000001;
const int maxn=50005;
int loc[maxn],speed[maxn];
int sum[maxn];
bool vis[maxn];
struct node
{
    int now,s,id;
    node(int now=0,int s=0,int id=0):now(now),s(s),id(id){}
    bool operator < (const node& t) const
    {
        if(s!=t.s)  return s>t.s;    //比较速度
        if(now!=t.now)  return now>t.now;   //当前位置
        return id<t.id;   //id
    }
};
vector<node> save;
int main()
{
    int T,Case=0;
    cin>>T;
    while(T--)
    {
        int N;
        cin>>N;

        for(int i=1;i<=N;i++)
        {
            scanf("%d%d",&loc[i],&speed[i]);
            sum[i]=loc[i]-speed[i];    //由于起始也要淘汰一名选手,所以先减掉,到后面开始模拟时加上即可
        }
        printf("Case #%d:\n",++Case);
        memset(vis,false,sizeof(vis));
        int kase=0;                     //方便打印加的一个标记
        for(int i=1;i<=min(N,550);i++)  //N可能比550小
        {
            int choose=-1,Max=-INF;
            for(int j=1;j<=N;j++)
            {
                if(vis[j])  continue;
                sum[j]+=speed[j];        
                if(Max<sum[j])  Max=sum[j],choose=j;
            }
            vis[choose]=true;
            if(kase++)  printf(" ");
            printf("%d",choose);
        }
        save.clear();
        for(int i=1;i<=N;i++)  if(!vis[i])  save.push_back(node(sum[i],speed[i],i));  // 剩余的选手
        sort(save.begin(),save.end());
        for(int i=0;i<save.size();i++)
        {
            if(kase++)  printf(" ");
            printf("%d",save[i].id);
        }
        printf("\n");
    }
    return 0;
}
 
 
posted @ 2015-08-28 09:00  wust_ouyangli  阅读(204)  评论(0编辑  收藏  举报