UVA196-Spreadsheet(拓扑排序)

Spreadsheet

 

In 1979, Dan Bricklin and Bob Frankston wrote VisiCalc, the first spreadsheet application. It became a huge success and, at that time, was the killer application for the Apple II computers. Today, spreadsheets are found on most desktop computers.

 

The idea behind spreadsheets is very simple, though powerful. A spreadsheet consists of a table where each cell contains either a number or a formula. A formula can compute an expression that depends on the values of other cells. Text and graphics can be added for presentation purposes.

 

You are to write a very simple spreadsheet application. Your program should accept several spreadsheets. Each cell of the spreadsheet contains either a numeric value (integers only) or a formula, which only support sums. After having computed the values of all formulas, your program should output the resulting spreadsheet where all formulas have been replaced by their value.

 

  figure22 
Figure: Naming of the top left cells

 

Input

The first line of the input file contains the number of spreadsheets to follow. A spreadsheet starts with a line consisting of two integer numbers, separated by a space, giving the number of columns and rows. The following lines of the spreadsheet each contain a row. A row consists of the cells of that row, separated by a single space.

 

A cell consists either of a numeric integer value or of a formula. A formula starts with an equal sign (=). After that, one or more cell names follow, separated by plus signs (+). The value of such a formula is the sum of all values found in the referenced cells. These cells may again contain a formula. There are no spaces within a formula.

You may safely assume that there are no cyclic dependencies between cells. So each spreadsheet can be fully computed.

 

The name of a cell consists of one to three letters for the column followed by a number between 1 and 999 (including) for the row. The letters for the column form the following series: A, B, C, ..., Z, AA, AB, AC, ..., AZ, BA, ..., BZ, CA, ..., ZZ, AAA, AAB, ..., AAZ, ABA, ..., ABZ, ACA, ..., ZZZ. These letters correspond to the number from 1 to 18278. The top left cell has the name A1. See figure 1.

 

Output

The output of your program should have the same format as the input, except that the number of spreadsheets and the number of columns and rows are not repeated. Furthermore, all formulas should be replaced by their value.

 

Sample Input

 

1
4 3
10 34 37 =A1+B1+C1
40 17 34 =A2+B2+C2
=A1+A2 =B1+B2 =C1+C2 =D1+D2

 

Sample Output

 

10 34 37 81
40 17 34 91
50 51 71 172


题意:给你一个电子表格,行用数字表示,列用大写字母表示,如A3表示第3行第1列,表示列的比较特殊,依次为A,B,C.....AA(27),AB(28)........有些格子直接给的数字,有的给的表达式,
如=A1+B1+C1,表示由这3个数相加。而且题目保证都有解,不会出现那种循环无解的情况。行或者是列可能达到18287,但所有的个数不会非常大,所以不能开成2维数组,开一维就可以了。最后要
打印所有的数。

解析:这题是一个拓扑排序,但是比较麻烦的是处理输入,如果某个格子是一个表达式,如(D1)=A1+B1+C1,那么把A1(1),B1(2),C1(3)这3个点分别于D1(4)连一条指向D1(4)的边,只
有先知道了A1,B1,C1,才能得到D1,设置一个数组indeg[](表示入度),如果有u->v,则indeg[v]++,然后把入度为0的点(u)加入队列,把这个点指向的其他点(v)的入度减1并v的值加上u
的值,如果其他点(v)的入度此时变0,就加入队列。跑一边拓扑排序即可。
代码如下:

#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<set>
#include<map>
#include<queue>
#include<vector>
#include<iterator>
#include<utility>
#include<sstream>
#include<iostream>
#include<cmath>
#include<stack>
using namespace std;
const int INF=1000000007;
const double eps=0.00000001;
const int maxn=2000005;                        // 开到百万即可
int row,col;                                   // 行,列
int val[maxn];                                 // 数值
int GetId(int x,int y){ return (x-1)*col+y; }  // 得到某个位置的id
string S[maxn];   
vector<int> G[maxn];                           // 用动态数组建立临接表,我比较喜欢用这种方式
int indeg[maxn];                               // 入度
int Get(const string& str)                     // 如果格子中是数值,则调用这个函数
{
    int ret=0;
    for(int i=0;i<str.size();i++)  ret=ret*10+str[i]-'0';
    return ret;
}
void change_to_num(const string& str,int id)
{
    int i;
    for(i=0;i<str.size();i++)
    {
        if(str[i]>='0'&&str[i]<='9')  break;           //  找到字母和数字的分界位置
    }
    int R=0,C=0;
    for(int j=0;j<i;j++) C=C*26+str[j]-'A'+1;          // 分别计算行跟列
    for(int j=i;j<str.size();j++)  R=R*10+str[j]-'0';
    int to=GetId(R,C);
    G[to].push_back(id);                               // 建表
    indeg[id]++;                                        
}
void link(const string& str,int id)
{
    int pre=1;                                            
    int i;
    for(i=1;i<str.size();i++)
    {
        if(str[i]=='+')
        {
            change_to_num(str.substr(pre,i-pre),id);     //单独分离出来如=A1+B1+C1,分离出A1,B1,
            pre=i+1;
        }
    }
    change_to_num(str.substr(pre,i-pre),id);             // 最后一个还要处理,如分离出最后的C1
}
void Get_Val(const string& str,int id)
{
    if(str[0]!='=')   val[id]=Get(str);                  // 如果是数值
    else   link(str,id);                                 // 要建立临接表
}
queue<int> que;
void toposort()
{
    while(!que.empty())  que.pop();
    for(int i=1;i<=row*col;i++)  if(!indeg[i])  que.push(i);    //入度为0 的加入队列
    while(!que.empty())
    {
        int now=que.front(); que.pop();
        for(int i=0;i<G[now].size();i++)
        {
            int to=G[now][i];
            indeg[to]--;
            val[to]+=val[now];                              //加上数值
            if(!indeg[to])  que.push(to);                   //变为0就加入队列
        }
    }
}
void ans_print()
{
    for(int i=1;i<=row;i++)
    {
        for(int j=1;j<=col;j++)
        {
            if(j!=1)  printf(" ");
            printf("%d",val[GetId(i,j)]);
        }
        printf("\n");
    }
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&col,&row);
        memset(val,0,sizeof(val));
        for(int i=1;i<=row*col;i++)  G[i].clear();
        memset(indeg,0,sizeof(indeg));
        for(int i=1;i<=row;i++)
        {
            for(int j=1;j<=col;j++)
            {
                int id=GetId(i,j);         // 得到他的id
                cin>>S[id];
                Get_Val(S[id],id);         // 处理
            }
        }
        toposort();                        // 拓扑排序
        ans_print();                       // 打印
    }
    return 0;
}


posted @ 2015-08-19 10:37  wust_ouyangli  阅读(282)  评论(0编辑  收藏  举报