【POJ 2115】CLooooops

C Looooops
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7898   Accepted: 1725

Description

A Compiler Mystery: We are given a C-language style for loop of type
for (variable = A; variable != B; variable += C) 
statement;

I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2k) modulo 2k.

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2k) are the parameters of the loop.

The input is finished by a line containing four zeros.

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate.

Sample Input

3 3 2 16 3 7 2 16 7 3 2 16 3 4 2 16 0 0 0 0

Sample Output

0 2 32766 FOREVER

Source

 

#include<iostream>
#include<stdio.h>
using namespace std;
__int64 exgcd(__int64 a,__int64 b,__int64 &x,__int64 &y)
{
 __int64 x1,y1,ggg;
 if (b==0)
 {
  x=1;
  y=0;
  return a;
 }
 else
  ggg=exgcd(b,a%b,x,y);
 x1=x;
 y1=y;
 x=y;
 y=x1-a/b*y1;
 return ggg;
}
int main()
{
 __int64 t,a,b,c,h,gg,x,y;
 int i,k;
 while(1)
 {
  scanf("%I64d%I64d%I64d%I64d",&a,&b,&c,&k);
  if ((a==0)&&(b==0)&&(c==0)&&(k==0)) break;
  t=b-a;
  h=1;
  for(i=1;i<=k;i++)
   h=h*2;
 // h<<k;
  gg=exgcd(c,h,x,y);
  if (t%gg!=0) printf("FOREVER\n");
  else
   printf("%I64d\n",(t/gg*x%h+h)%(h/gg));
 }
 //cin>>i;
 return 0;
}

 

posted @ 2019-07-09 20:05  #Cookies#  阅读(180)  评论(0编辑  收藏  举报