随笔 - 145  文章 - 0  评论 - 6  阅读 - 18万

背包问题---DP

 Problem 2214 Knapsack problem

Accept: 412    Submit: 1650
Time Limit: 3000 mSec    Memory Limit : 32768 KB

 Problem Description

Given a set of n items, each with a weight w[i] and a value v[i], determine a way to choose the items into a knapsack so that the total weight is less than or equal to a given limit B and the total value is as large as possible. Find the maximum total value. (Note that each item can be only chosen once).

 Input

The first line contains the integer T indicating to the number of test cases.

For each test case, the first line contains the integers n and B.

Following n lines provide the information of each item.

The i-th line contains the weight w[i] and the value v[i] of the i-th item respectively.

1 <= number of test cases <= 100

1 <= n <= 500

1 <= B, w[i] <= 1000000000

1 <= v[1]+v[2]+...+v[n] <= 5000

All the inputs are integers.

 Output

For each test case, output the maximum value.

 Sample Input

1
5 15
12 4
2 2
1 1
4 10
1 2

 Sample Output

15
 
代码如下:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
/*
    0-1背包问题:
    因为重量太大,肯定不能按照原来的标准模型套用,开不了那么大的数组
    但是总价值却小于5000;
 
    根据价值构造dp方程,找到最小的重量能够得到这个价值
    dp[100]=15,就是代表使得价值为100的最小重量为15;
*/
 
 
#include <iostream>
#include<cstring>
#include<cstdio>
using namespace std;
const int maxs = 600;
int n,B;
int w[maxs];
int v[maxs];
int dp[5005];
int main()
{
    freopen("in.txt","r",stdin);
    int T;
    cin>>T;
    while(T--)
    {
        int sum = 0;
        scanf("%d%d\n",&n,&B);
        for(int i=1;i<=n;i++)
            scanf("%d%d",&w[i],&v[i]),sum+=v[i];
        memset(dp,0x3f,sizeof(dp));
        dp[0]=0;
        for(int i=n;i>=1;i--)
            for(int j=sum;j>=v[i];j--)
                dp[j]=min(dp[j],dp[j-v[i]]+w[i]);
        for(int i=sum;i>=0;i--)
            if(dp[i]<=B)
            {
                printf("%d\n",i);
                break;
            }
 
    }
    return 0;
}

 

posted on   wastonl  阅读(223)  评论(0编辑  收藏  举报
编辑推荐:
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
阅读排行:
· TypeScript + Deepseek 打造卜卦网站:技术与玄学的结合
· 阿里巴巴 QwQ-32B真的超越了 DeepSeek R-1吗?
· 【译】Visual Studio 中新的强大生产力特性
· 10年+ .NET Coder 心语 ── 封装的思维:从隐藏、稳定开始理解其本质意义
· 【设计模式】告别冗长if-else语句:使用策略模式优化代码结构
< 2025年3月 >
23 24 25 26 27 28 1
2 3 4 5 6 7 8
9 10 11 12 13 14 15
16 17 18 19 20 21 22
23 24 25 26 27 28 29
30 31 1 2 3 4 5

点击右上角即可分享
微信分享提示