WUSTOJ 1341: Lake and Island(Java)
Description
北园孩子的专属福利来啦~学校从北区宿舍到湖心岛修建了一条通道让北园的同学们可以上去一(kuang)同(xiu)玩(en)耍(ai),这一天,IcY向ahm001发了一条短信
东门之杨,其叶将将,昏以为期,明星煌煌。
东门之杨,其叶肺肺,昏以为期,明星晢晢。
——《诗经·国风·陈风》
ahm001知道IcY在湖心等待他,但身为数学系的ahm001强迫症,只能就是每一步只能走的分米数只能为质数,并且尽量的要小(傲娇 ><)现在ahm001在北区人行道上(位置为0),Icy的位置是湖心岛(位置为x)
Input
人行道到湖心岛的距离正整数x,x<=1000(单位:分米)
Output
第一行为ahm需要走的步数n
接下来一行有n个整数,即ahm001每一步需要踏出的距离(单位:分米)
如果不存在合法的方案,输出-1
Sample Input
2
5
Sample Output
1
2
2
2 3
分析💬
注意:x = 1
的情况。
代码💻
/**
* Time 700ms
* @author wowpH
* @version 1.1
* @date 2019年7月3日下午3:38:47
* Environment: Windows 10
* IDE Version: Eclipse 2019-3
* JDK Version: JDK1.8.0_112
*/
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
while (sc.hasNext()) {
int x = sc.nextInt();
if (1 == x) {
System.out.println(-1);
} else {
int n = x / 2;
System.out.println(n);
for (int i = 1; i < n; ++i) {
System.out.print(2 + " ");
}
if (0 == x % 2) {
System.out.println(2);
} else {
System.out.println(3);
}
}
}
sc.close();
}
}