Red and Black
Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 21143 | Accepted: 11292 |
Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
Sample Output
45 59 6 13
Source
#include <cstdio>
char a[22][22];
int w,h;
int f(int i,int j)
{if(i<0||i>=h||j<0||j>=w)
return 0;
if(a[i][j]=='#') return 0;
else {
a[i][j]='#';
return 1+f(i+1,j)+f(i-1,j)+f(i,j+1)+f(i,j-1);
}
}
int main ()
{int i,j;
while(scanf("%d%d",&w,&h),w!=0&&h!=0)
{for(i=0;i<h;i++)
scanf("%s",a[i]);
for(i=0;i<h;i++)
for(j=0;j<w;j++)
if(a[i][j]=='@')
printf("%d\n",f(i,j));
}
return 0;
}
DFS=。=居然把==写成=了。“a[i][j]=='#'”