离散化

整数离散化

描述: 有这么一个数字序列,其中数字的值域非常大,但是个数有限,如何存储?

这时候需要用到离散化的方法(或者说哈希),下面介绍的是保序的离散化(下标小的一定在前面,大的一定在后面)

两个关键问题

  • 原数组可能存在相同数字(去重)
  • 如何算出x离散化后的值 (二分)

模板

vector<int> alls; // 存储所有待离散化的值
sort(alls.begin(), alls.end()); // 将所有值排序
alls.erase(unique(alls.begin(), alls.end()), alls.end());   // 去掉重复元素

// 二分求出x对应的离散化的值
int find(int x) // 找到第一个大于等于x的位置
{
    int l = 0, r = alls.size() - 1;
    while (l < r)
    {
        int mid = l + r >> 1;
        if (alls[mid] >= x) r = mid;
        else l = mid + 1;
    }
    return r + 1; // 映射到1, 2, ...n
}

例题

假定有一个无限长的数轴,数轴上每个坐标上的数都是 0。

现在,我们首先进行 n 次操作,每次操作将某一位置 x 上的数加 c。

接下来,进行 m 次询问,每个询问包含两个整数 l 和 r,你需要求出在区间 [l,r][�,�] 之间的所有数的和。

输入格式

第一行包含两个整数 n 和 m。

接下来 n 行,每行包含两个整数 x 和 c。

再接下来 m 行,每行包含两个整数 l 和 r。

输出格式

共 m 行,每行输出一个询问中所求的区间内数字和。

数据范围

\(−10^9≤x≤10^9\),
\(1≤n,m≤10^5\),

\(−10^9≤l≤r≤10^9\),
\(−10000≤c≤10000\)

输入样例

3 3
1 2
3 6
7 5
1 3
4 6
7 8

输出样例:

8
0
5

代码

# include<iostream>
# include<vector>
# include<algorithm>

using namespace std;

typedef pair<int, int> PII;
const int N = 3e5+ 10;
int n, m;
int a[N], s[N];

vector<int> alls;
vector<PII> adds, query;


int find(int x)
{
    int l = 0, r = alls.size() - 1;
    while (l < r)
    {
        int mid = l + r >> 1;
        if (alls[mid] >= x) r = mid;
        else l = mid + 1;
    }
    return r + 1; // 映射到1, 2, ...n
}

int main(){
    cin >> n >> m;
    for(int i = 0; i < n; i ++){
        int  x, c;
        cin >> x >> c;
        adds.push_back({x, c});
        alls.push_back(x);
    }  

    for(int i = 0; i < m; i ++){
        int l, r;
        cin >> l >> r;
        query.push_back({l, r});

        alls.push_back(l);
        alls.push_back(r);
    }

    sort(alls.begin(), alls.end());
    alls.erase(unique(alls.begin(), alls.end()), alls.end());

    for(auto item : adds) {
        int x = find(item.first);
        a[x] += item.second;
    }

    // 预处理前缀和
    for(int i = 1; i <= alls.size(); i ++) {
        s[i] = s[i - 1] + a[i];
    }

    // 处理询问
    for(auto item : query){
        int  l = find(item.first);
        int  r = find(item.second);
        cout << s[r] - s[l - 1] << endl;
    }

    return 0;
} 
posted @ 2023-03-18 15:03  我就一水  阅读(28)  评论(0编辑  收藏  举报